VirusScan Enterprise について

VirusScan Enterprise は、ウイルス、ワーム、トロイの木馬などから使用中の環境を保護します。拡張性に優れた保護、高速パフォーマンス、およびモバイル向けのデザインが特徴です。また、アクセス ポイント違反、攻撃でオーバーフローしたバッファ、および不審なコードやプログラムからシステムを保護します。脅威を検出すると、使用中の環境を保護するよう設定されたアクションを実行します。このリリースの新機能については、『VirusScan Enterprise リリース ノート』を参照してください。

本書では、VirusScan Enterprise の設定および使用方法を説明します。

VirusScan Enterprise はスタンドアロン製品として設定できます。また、ePolicy Orchestrator バージョンの 3.6.1 と 4.0 を使用して、VirusScan Enterprise ポリシーを中央で管理および実施し、クエリとダッシュボードを使用して、動作と検出を追跡することができます。

注: 本書では、ePolicy Orchestrator 4.0 の使用方法について説明します。ePolicy Orchestrator のいずれかのバージョンの使用方法については、その製品マニュアルを参照してください。

目次

  • VirusScan Enterprise の使用方法
  • はじめに
  • 最初に行う作業
  • 製品情報の取得先


VirusScan Enterprise の使用方法

VirusScan Enterprise software を使用して、ユーザの環境を潜在的な脅威から保護してください。

インストール直後の VirusScan Enterprise は、出荷時に同梱された検出定義 (DAT) ファイルを使用してユーザ環境のセキュリティ全般を保護するよう設定されています。VSE を使用するか、クライアント コンピュータに配布する前に、環境のポリシーとニーズを定義し、それに基づいて VSE を設定してから、検出定義をアップデートしておくことをお勧めします。

VirusScan Enterprise の各コンポーネントまたは機能は、使用中の環境を保護する役割を担っています。

防止

すべてのデータ ソースを確実に保護するためのセキュリティ ニーズを定義し、使用中の環境にアクセスできるようになる前に侵入を阻止するための効果的な方法を開発します。次の機能を設定して侵入を防止します。
  • ユーザ インターフェイス セキュリティ - 表示およびパスワード保護を設定して、ユーザ インターフェイスへのアクセスを制御します。
  • アクセス保護 — アクセス保護ルールを使用して、コンピュータがファイル、レジストリ、およびポートに関して好ましくない動作をしないように保護します。AntiSpyware Enterprise Module をインストールしている場合、不審なスパイウェアに関連する潜在的な脅威から保護するルールが追加されています。
  • バッファ オーバフロー保護 - 攻撃でオーバフローしたバッファにより、コンピュータ上で任意のコードが実行されることを防止します。
  • 不審なプログラムの保護 - スパイウェアやアドウェアなど、不審なプログラムをコンピュータから削除します。

スキャン

侵入が発生したときにその侵入を検出するための効果的な方法を開発します。次の機能を設定して脅威を検出します。
  • アップデート タスク - 検出定義とスキャン エンジンを McAfee ダウンロード Web サイトから自動的に取得します。
  • オンアクセス スキャン — ファイルをディスクから読み込むときおよびディスクに書き出すときに、あらゆるソースに潜む脅威を検出します。AntiSpyware Enterprise Module をインストールした場合、Cookie フォルダ内で、不審な Cookie をスキャンすることもできます。
  • オンデマンド スキャン タスク - 即時スキャンとスケジュールしたスキャンのタスクで潜在的脅威を検出します。AntiSpyware Enterprise Module をインストールした場合、不審な Cookie や、以前に駆除されなかったスパイウェア関連のレジストリ エントリをスキャンすることもできます。
  • 配信時およびオンデマンド電子メール スキャン - 配信時スキャンで電子メール メッセージ、添付ファイル、およびパブリック フォルダをチェックし、Microsoft Outlook 電子メール クライアントの潜在的な脅威を検出します。Lotus Notes 電子メール クライアントの潜在的な脅威は、メッセージにアクセスするときに検出します。
  • Quarantine Manager のポリシー - 隔離の場所および隔離アイテムの保管期間を指定します。必要に応じて隔離したアイテムを復元します。

通知

アラートおよび通知 - 侵入が検出されたときには、アラートが発せられるように設定します。

対応

製品のログ ファイル、自動アクション、および他の通知機能を使用して、検出の処理に最適な方法を決定します。

  • ログ ファイル — 製品のログ ファイルを監視して検出したアイテムの履歴を表示します。

  • クエリおよびダッシュボード - ePolicy Orchestrator のクエリおよびダッシュボードを使用して、スキャン動作および検出を監視します。
  • アクション - 検出時にアクションを実行するように各機能を設定します。

補足情報

製品の詳細については、以下のトピックを参照してください。

  • ユーザ インターフェイス オプションへのアクセス — さまざまな方法で製品のスタンドアロン バージョンにアクセスします。

  • スキャン アイテムの追加と除外 - スキャンするファイルの種類のリストをスキャナ別にきめ細かく設定できます。

  • タスクのスケジュール —オンデマンド スキャン、アップデート、およびミラーのタスクを特定の日時または間隔で実行するようにスケジュール設定します。

  • コマンド ライン オプションの設定 — オンデマンド スキャンとアップデートのタスクをコマンド ラインから設定します。

  • リモート システムとの接続 — インストールされている VirusScan Enterprise をリモート システムと接続して、スキャン タスクやアップデート タスクの変更、スケジュール設定などのアクションを実行したり、オンアクセス スキャナの有効と無効を切り替えたりします。

  • 解析用脅威サンプルの送信 — WebImmune を経由して未検出の潜在的な脅威サンプルを Avert Labs に送信します。

  • Avert Labs 脅威ライブラリへのアクセス — Avert Labs 脅威ライブラリの情報にアクセスします。

  • トラブルシューティング — 製品のインストール修復方法とよく寄せられる質問に関する情報を取得します。


はじめに

これ以降は、このマニュアルで説明する手順を実行するために必要な権限をユーザが所有していることを前提に話を進めていきます。

  1. McAfee ダウンロード サイトから VirusScan Enterprise 8.7i の製品ファイルを取得します。これらのファイルには、製品のインストール ファイル、製品パッケージ ファイル、レポート拡張、およびヘルプ拡張のファイル、および ePolicy Orchestrator 移行ツールが含まれる場合があります。インストールと既知の問題については、VirusScan Enterprise 8.7i リリース ノート を参照してください。
  2. ePolicy Orchestrator の場合は、チェックイン ウィザードを使用して、製品拡張とレポート拡張のファイルおよび製品パッケージ ファイルをリポジトリに追加します。VirusScan Enterprise の以前のバージョンからアップグレードし、設定を保持する場合は、ePolicy Orchestrator 移行ツールを実行します。詳細については、ePolicy Orchestrator 製品マニュアルを参照してください。
  3. VirusScan Enterprise のスタンドアロン インストールの場合、製品の詳細なインストール方法については『インストール ガイド』を参照してください。前のバージョンの VirusScan Enterprise からアップグレードする場合、設定の保存方法については『インストール ガイド』を参照してください。


最初に行う作業

インストール直後の VirusScan Enterprise は、出荷時に同梱された検出定義を使用してユーザ環境のセキュリティ全般を保護するよう設定されています。最新の検出定義ファイルを入手し、自社の要件を満たすよう設定をカスタマイズした後に、クライアント システムにこの製品を配布してください。

タスク

製品のインストールが完了したら、直ちに次の作業を行ってください。

  1. ユーザ インターフェイス セキュリティの設定。表示とパスワードのオプションを設定して、特定のコンポーネントまたは VirusScan Enterprise ユーザ インターフェイス全体にユーザがアクセスできないようにします。詳細については、「ユーザ インターフェイスへのアクセスの制御」を参照してください。
  2. 検出定義のアップデート。[今すぐ更新] タスクを実行して、最新版の検出定義が確実に使用されるようにします。詳細については、「検出定義のアップデート」を参照してください。
  3. 侵入の防止。以下の機能を設定して、潜在的な脅威がシステムにアクセスすることを防ぎます。
    • アクセス保護。コンピュータに望ましくない変更が加えられないようアクセス保護ルールを設定し、McAfee プロセスを終了させないためのオプションを有効にします。詳細については、「システムのアクセス ポイントの保護」を参照してください。
    • バッファ オーバーフロー保護。バッファ オーバフロー検出を有効にし、除外対象を指定します。詳細については、「バッファ オーバーフロー攻撃のブロック」を参照してください。
    • 不審なプログラム ポリシー。不審なプログラムを検出するためにオンアクセス スキャナ、オンデマンド スキャナ、および電子メール スキャナで使用するポリシーを設定します。事前に定義されているリストから、検出する不審なプログラムのカテゴリを選択し、次に、検出または実行する追加のプログラムを定義します。詳細については、「不審なプログラムの制限」を参照してください。
  4. 侵入の検知。システムに対する潜在的な脅威を検出し、検出時にユーザに通知してアクションを実行するように以下の機能を設定します。
    • 自動アップデート。最新の検出定義、スキャン エンジン、および製品アップグレードを取得するためのアップデート タスクを設定します。詳細については、「検出定義のアップデート」を参照してください。
    • オンアクセス スキャン。環境内で潜在的な脅威にアクセスされたときにその脅威を検出し、アクションを実行するようにスキャナを設定します。不審なプログラムのスキャンを有効にします。AntiSpyware Enterprise Module をインストールしている場合、Cookie フォルダの Cookie もスキャンできます。詳細については、「アイテムのオンアクセス スキャン」を参照してください。
    • オンデマンド スキャン。環境内で潜在的な脅威を検出し、アクションを実行するようにスキャン タスクを設定します。不審なプログラムのスキャンを有効にします。AntiSpyware Enterprise Module をインストールした場合、Cookie フォルダ内の不審な Cookie や、以前に駆除されなかったスパイウェア関連のレジストリ エントリをスキャンすることもできます。詳細については、「アイテムのオンデマンド スキャン」を参照してください。
    • 電子メール スキャナ。Microsoft Outlook および Lotus Notes 電子メール クライアントの配信時スキャン／オンデマンド スキャンを設定します。不審なプログラムのスキャンを有効にします。詳細については、「配信時とオンデマンドの電子メール スキャン」を参照してください。
  5. アラート送信と脅威の隔離。脅威が検出されたときのユーザへの通知と、隔離アイテムの管理について設定します。
    • アラートおよび通知。検出の通知およびアラートをいつどのような方法で受信するかを設定します。詳細については、「アラートおよび通知の設定」を参照してください。
    • Quarantine Manager のポリシー。隔離フォルダの場所、および隔離されたアイテムが自動的に削除されるまでの隔離日数を設定します。詳細については、「隔離ポリシーの定義」を参照してください。


製品情報の取得先

この製品マニュアルは、新製品の評価から既存の製品の管理に至る、製品の実装における各フェーズで必要となる情報を提供することを目的としています。製品によっては、追加のマニュアルが用意されている場合があります。製品のリリース後は、McAfee ServicePortal からアクセス可能なオンライン知識ベースに、製品に関する追加情報が掲載されます。

インストール フェーズ

セットアップ フェーズ

メンテナンス フェーズ

インストール前、インストール中、およびインストール後

リリース ノート

  • 現在のリリースで確認されている問題
  • 最後のリリース以降に解決された問題
  • 製品または製品のマニュアルに対する最新の変更点

インストール ガイド

  • 本稼動環境でのソフトウェアの準備、インストールおよび配備

製品稼動時

製品ガイドおよびオンライン ヘルプ

  • 環境に合わせたソフトウェアの設定およびカスタマイズ

オンライン ヘルプ

  • ePolicy Orchestrator による製品の管理および配備
  • 製品のオプションに関する詳細情報

ソフトウェアの管理

オンライン ヘルプ

  • ソフトウェアの管理
  • リファレンス情報
  • 製品ガイドに記載されているすべての情報

知識ベース (knowledge.mcaf)

  • リリース ノートおよびマニュアル
  • 製品に関する補足情報

  • 既知の問題に対する解決方法

McAfee エンタープライズ製品のリリース ノートおよびマニュアルの取得

  1. knowledge.mcafee.com にアクセスし、[Useful links (便利なリンク)] で [Product Documentation (製品マニュアル)] を選択します。
  2. <製品名> → <製品バージョン> を選択し、マニュアルのリストから必要なマニュアルを選択します。

製品からヘルプ トピックへのアクセス

ヘルプのトピックにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[?] をクリックし、[VirusScan Enterprise 8.7i] を選択します。

    オプションの定義を表示するには、ポリシーまたはタスクのタブで [?] をクリックします。

  • VirusScan コンソールからは、[ヘルプ] メニューの [ヘルプ トピック] を選択します。
    注: 製品をインストールした後、初めて [ヘルプ] にアクセスすると、ヘルプ ファイルをダウンロードするかどうかを尋ねるメッセージが表示されます。[はい] をクリックしてヘルプ ファイルをダウンロードし、インストール ディレクトリにインストールします。

    オプションの定義を表示するには、機能プロパティのタブで [ヘルプ] をクリックします。


ユーザ インターフェイスへのアクセスの制御

クライアント コンピュータのインターフェイスのセキュリティを設定することは、環境を保護するために重要な点です。管理者は VirusScan Enterprise インターフェイスに対するユーザのアクセスを制御できます。パスワードを設定して、選択した機能にユーザがアクセスしたり変更を加えたりすることを防止してください。また、必要に応じて、ユーザ インターフェイスをロックしたりロックを解除したりすることもできます。

目次

  • パスワードの設定がユーザに与える影響
  • ユーザ インターフェース セキュリティの設定


パスワードの設定がユーザに与える影響

悪意のあるユーザを防止するためのユーザ インターフェイス パスワードを設定します。クライアント コンピュータのユーザ インターフェイスをパスワードで保護すると、ユーザは次のような影響を受けます。

  • [管理者以外] ‐ 管理者権限のないユーザ。管理者以外のユーザは、すべての VirusScan Enterprise アプリケーションを読み取り専用モードで実行します。設定パラメータの表示、保存したスキャンの実行、および任意のときすぐにスキャンやアップデートを実行することはできます。設定パラメータの変更、保存したスキャンの作成、削除または変更、あるいはタスクのアップデートはできません。
  • [管理者] ‐ 管理者権限のあるユーザ。保護されたタブおよびコントロールを読み取り/書き込みモードで使用するために、管理者はパスワードを入力する必要があります。保護されたアイテムに対してパスワードを指定しない場合、そのアイテムは読み取り専用モードで表示されます。


ユーザ インターフェース セキュリティの設定

[ユーザ インターフェイス] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [ユーザ インターフェイス ポリシー] を選択します。

  • VirusScan コンソールから、[ツール] → [ユーザ インターフェイス オプション] を選択します。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブの説明

タブ | 説明
表示オプション
  • ユーザに表示されるシステム トレイ アイコン オプションを指定します。
  • リモート コンピュータに接続できるようにします。
  • コンソールの言語を設定します。
パスワード オプション | システム全体、またはアイテムを選択して、パスワード セキュリティを指定します。


システムのアクセス ポイントの保護

アクセス保護機能は、指定したポート、ファイル、共有、レジストリ キー、およびレジストリ値へのアクセスを制限することで、コンピュータに対する望ましくない変更を阻止します。また、ユーザによって McAfee プロセスが終了されないように保護します。この保護機能は、ウイルスの発生前と発生中のどちらでも、非常に重要です。

この機能では、定義済みのルールとカテゴリおよびユーザ定義ルールを使用して、アクセスを許可するアイテムおよび許可しないアイテムを指定します。各ルールは、アクセス ポイント違反の発生時にアクセスをブロックする、違反をレポートする、またはその両方の動作を行うように設定できます。定義済みのルールとカテゴリは、McAfee アップデート サイトから内容を更新する必要があります。

注: アクセス保護機能は、オンアクセス スキャナを使用して、アクセス ポイント違反を検出します。ポート、ファイル、共有、およびレジストリのキーと値へのアクセスを試みている者がいることをアクセス保護機能で検知するには、オンアクセス スキャナを有効にする必要があります。

目次

  • アクセス保護ルールを定義する方法
  • アクセス ポイント違反と VirusScan Enterprise の対応
  • ユーザ定義ルールの種類
  • アクセス保護の設定


アクセス保護ルールを定義する方法

ルールのタイプと、保護のレベルは次のとおりです。

ルール タイプの説明

ルール タイプ 説明
ウイルス対策

これらの設定済みルールは、マルウェアの脅威による一般的な動作からコンピュータを保護します。設定を有効化、無効化、または変更できますが、これらのルールを削除することはできません。

次に、これらのルールの例を 2 つ示します。

  • 重要なプロセスの無効化または変更、実行可能ファイルのリモート作成または変更、実行可能ファイルのハイジャック、Windows プロセスのなりすまし、および大量メール送信ワームによるメール送信を防止します。
  • パスワードと E-mail アドレスが盗難されないように電話帳ファイルを保護します。

これらの保護レベルはウイルス対策ルールに適用されます。

  • 標準の保護
  • 最大の保護
  • アウトブレーク コントロール
共通

これらの設定済みルールは、使用頻度の高いファイルや設定の変更を防止します。設定を有効化、無効化、または変更できますが、これらのルールを削除することはできません。

次に、これらのルールの例を 3 つ示します。

  • McAfee のファイルと設定の変更を防止します。
  • Mozilla と Firefox のファイルと設定、Internet Explorer の設定、およびネットワーク設定を保護します。
  • ブラウザ ヘルパー オブジェクトのインストール、および Temp フォルダからのプログラムの自動実行を防止します。

これらの保護レベルは共通ルールに適用されます。

  • 標準の保護
  • 最大の保護
仮想マシン保護

設定済みのルールにより VMWare プロセスの終了と VMWare ファイルの変更を防止します。設定を有効化、無効化、または変更できますが、これらのルールを削除することはできません。

ルールの例は次のとおりです。
  • VMWare プロセスが終了されないようにする。
  • VMWare ワークステーション、サーバ、または仮想マシン ファイルの変更を防止する。
ユーザ定義

これらのカスタム ルールは、ウイルス対策および共通ルールによって提供される保護を補完します。
スパイウェア対策

AntiSpyware Enterprise Module をインストールしている場合、不審なスパイウェアに関連する脅威から保護するルールが追加されています。

ルールの例は次のとおりです。
  • Internet Explorer のお気に入りと設定を保護する。
  • Temp フォルダからのプログラム実行とスクリプト実行を防止する。

保護レベルの説明

保護レベル | 説明
標準 | いくつかの重要な設定やファイルが変更されないよう保護する、ウイルス対策および共通のルール。ただし通常は、正当なソフトウェアのインストールと実行は許可します。
最大 | 最も重要な設定とファイルが変更されないよう保護する、ウイルス対策および共通のルール。このレベルに設定すると保護は標準よりも強化されますが、正当なソフトウェアのインストールができなくなる可能性もあります。ソフトウェアをインストールできない場合、まずアクセス保護機能を無効にしてからインストールを行い、インストール後に再びこの機能を有効にすることをお勧めします。
アウトブレーク コントロール | DAT ファイルがリリースされるまで、破壊的なコードによるコンピュータへのアクセスをブロックするウイルス対策ルール。これらのルールは、アウトブレーク時に共有へのアクセスをブロックするよう事前に設定されています。


アクセス ポイント違反と VirusScan Enterprise の対応

アクセス ポイント違反が発生した場合、次に示す処理が行われます。

  • 違反を検出したルールに [レポート] オプションを選択していた場合、情報がログ ファイルに記録されます。
  • [アラートのプロパティ] を設定すると、イベントはローカルのイベント ログおよび SNMP に記録されます。
  • Alert Manager または ePolicy Orchestrator あるいはその両方で上に述べた処理を設定しておくと、イベントがこれらの製品にレポートされます。
  • 違反を検知したルールに設定しておいたアクションに応じて、ブロックまたはレポートあるいはその両方のアクションが実行されます。

  • クライアント システムでは、システム トレイ アイコンの周囲に赤い枠が表示され、リセットしなければ 30 分間表示されます。

    注: アイコンをリセットするには、システム トレイ アイコンから [アクセス保護ログ ファイル] を開きます。その他の方法でログ ファイルを開くと、アイコンは通常の状態にリセットされません。


ユーザ定義ルールの種類

ルールの 3 つの種類のいずれかを選択します。

ルールの詳細

ルール | 説明
ポートのブロック ルール | 特定のポートまたはある範囲のポートで着信または発信のネットワーク トラフィックをブロックします。 注: ポートをブロックすると、TCP (Transmission Control Protocol) アクセスと UDP (User Datagram Protocol) アクセスがブロックされます。
ファイルおよびフォルダのブロック ルール | ファイルおよびフォルダへの読み取りアクセスもしくは書き込みアクセスをブロックします。 注: ファイルまたはフォルダへのアクセス制限は、管理者により解除されるまで継続します。これは侵入防止に役立ち、アウトブレーク時に侵入が拡散するのを阻止します。
レジストリのブロック ルール | 読み取り、書き込み、作成、または削除のアクションをブロックすることにより、レジストリのキーまたは値を保護します。


アクセス保護の設定

[アクセス保護] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [アクセス保護ポリシー] を選択します。

  • VirusScan コンソールからは、[アクセス保護] プロパティを開きます。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブの説明

タブ 説明
アクセス保護
  • アクセス保護を有効にします。
  • ルールを設定します。
  • McAfee プロセスが終了されることを防ぎます。
レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。


ウイルス対策ルールと共通ルールの設定

事前に定義されたウイルス対策ルールまたは共通ルールあるいはその両方を使用して、望ましくない変更からコンピュータを保護します。これらのルールは有効化と編集はできますが、削除はできません。

タスク

  1. 左側のペインで [ウイルス対策] カテゴリまたは [共通] カテゴリを選択してから、右側のペインで特定のルールを選択します。
  2. [ブロック] または [レポート] あるいはその両方のオプションを設定します。
  3. [編集] をクリックして、ルールの詳細を設定します。


ユーザ定義ルールの設定

ユーザ定義ルールを作成し、編集して、ウイルス対策ルールおよび共通ルールによる保護を補完します。

タスク

  1. 左側のペインで [ユーザ定義ルール] カテゴリをクリックしてから、[新規] をクリックします。
  2. ルールの種類を選択します。
  3. 必要に応じて、[ブロック] と [レポート] の各アクションを変更します。
  4. [編集] をクリックして、設定を変更します。


ポートのブロック ルールの設定

ユーザが指定された受信ポートまたは送信ポート (あるいはその両方) にアクセスできないようにブロックします。

オプションの定義

オプション | 定義
ルール名 | このルールの名前を入力します。
組み入れるプロセス | 指定されたプロセスへのアクセスを制限します。
除外するプロセス | 指定されたプロセスへのアクセスを許可します。
開始ポート | 最初のポート番号を指定します。ポートは個別にまたはある範囲の最初のポート番号で指定することもできます。 注: McAfee エージェント、Entercept エージェント、または Host Intrusion Prevention エージェントで使用されるポートへのアクセスをブロックしても、このエージェントのプロセスは信頼されているため、ブロックされているポートとの通信は可能です。これらのエージェントのプロセスに関連のないトラフィックはブロックされます。
終了ポート | ポート範囲の最後のポート番号を指定します。
受信 | ネットワークを介した指定されたポートへのアクセスを拒否します。
送信 | ローカル プロセスからネットワーク上の指定されたポートへのアクセスを拒否します。


ファイル/フォルダのブロック ルールの設定

指定されたファイルまたはフォルダに対してユーザが実行するアクションを防止します。

オプションの定義

オプション | 定義
ルール名 | このルールの名前を入力します。
組み入れるプロセス | 指定されたプロセスへのアクセスを制限します。
除外するプロセス | 指定されたプロセスへのアクセスを許可します。
ブロックするファイルまたはフォルダの名前 | 指定されたファイルまたはフォルダへのアクセスをブロックします。
ファイルの参照 | 目的のファイルに移動します。
フォルダの参照 | 目的のフォルダに移動します。
ファイルに対する読み取りアクセス | 指定ファイルへの読み取りアクセスをブロックします。
ファイルに対する書き込みアクセス | 指定ファイルへの書き込みアクセスをブロックします。
実行中のファイル | 指定フォルダ内でのファイルの実行をブロックします。
新規ファイルの作成 | 指定フォルダ内でのファイルの新規作成をブロックします。
ファイルの削除 | 指定フォルダ内からのファイルの削除をブロックします。


レジストリのブロック ルールの設定

ユーザが特定のレジストリのキーまたは値で取るアクションをブロックします。

オプションの定義

オプション | 定義
ルール名 | このルールの名前を指定します。
組み入れるプロセス | 指定されたプロセスへのアクセスを制限します。
除外するプロセス | 指定されたプロセスへのアクセスを許可します。
保護するレジストリのキーまたは値 このレジストリのキーまたは値を保護します。
  • ルート キーまたは値をドロップダウン リストから選択します。
  • キーまたは値をテキスト ボックスに入力します。
ルート キーまたは値をドロップダウン リストから選択するのは、オプションです。キーまたは値を指定するには、次のいずれかの方法を使用します。
  • ルート キーまたは値をドロップダウン リストから選択し、キーまたは値への残りのパスをテキスト ボックスに入力します。
  • キーまたは値へのフル パスをテキスト ボックスに入力します。
ルール タイプ ルールの種類を選択します。
  • キー - 指定したキーを保護します。
  • 値 - 指定した値を保護します。
キーまたは値への書き込み | 指定したキーまたは値への書き込みをブロックします。
キーまたは値の作成 | 指定したキーまたは値の作成をブロックします。
キーまたは値の削除 | 指定したキーまたは値の削除をブロックします。


特定のプロセスの組み入れ/除外

オプションの定義

ルールの詳細を編集して、検出の対象にする、または検出対象から除外する特定のプロセスを指定します。

オプション | 説明
ルール名 | このルールの名前を入力します。たとえば、「レジストリ エディタおよびタスク マネージャが無効にされることを防止します」などです。
組み入れるプロセス | ここに登録したプロセスへのアクセスを制限します。正確なプロセス名を指定します。または、ワイルドカードを使用して *.EXE など幅広い範囲のプロセスを指定し、SETUP.EXE など信頼できるプロセスを除外対象として指定します。たとえば、* を指定するとすべてのプロセスが組み入れられます。
除外するプロセス | ここに登録したプロセスへのアクセスを許可します。正確なプロセス名を指定します。たとえば、avtask.exe、cfgwiz,exe、fssm32.exe、giantantispywar*、kavsvc.exe、mmc.exe、navw32.exe、nmain.exe、rtvscan.exe を除外対象として指定します。


ユーザ定義ルールの削除

作成したが使用していないルールを削除します。

タスク

  1. 左側のペインで [ユーザ定義ルール] カテゴリをクリックしてから、右側のペインで削除するルールをクリックします。
  2. [削除] をクリックします。
    注: ルールを削除せずに無効にするには、[ブロック] アクションと [レポート] アクションの選択を解除します。必要に応じて、ルールを再び有効にできます。


バッファ オーバーフロー攻撃のブロック

バッファ オーバフロー保護では、攻撃でオーバフローしたバッファにより、任意のコードが実行されることを防止します。ユーザモードの API 呼び出しを監視し、バッファ オーバフローの結果として発生した呼び出しを識別します。

オプションを設定していた場合に侵害の試行が検出されると、情報が動作ログに記録され、[オンアクセス スキャンのメッセージ] ダイアログ ボックスに表示されます。

VirusScan Enterprise では、バッファ オーバフローおよびアクセス保護 DAT ファイルを使用して、Internet Explorer、Microsoft Outlook、Outlook Express、Microsoft Word、MSN Messenger など、約 20 種類のアプリケーションを保護することが可能です。

目次

  • バッファ オーバーフロー攻撃手段の定義
  • バッファ オーバーフロー保護の設定


バッファ オーバーフロー攻撃手段の定義

バッファ オーバフロー攻撃とは、アプリケーションやプロセスに存在する設計上の欠陥を攻撃し、コンピュータ上で任意のコードを実行する攻撃手法の 1 つです。アプリケーションでデータを格納するバッファ サイズは固定されています。攻撃者が大量のデータまたはコードをバッファの 1 つに送りつけると、そのバッファはオーバフローします。すると、コンピュータはオーバフローしたコードをプログラムとして実行します。コードはアプリケーションのセキュリティ レベル (通常は管理者権限または極めて高い権限レベル) で実行されます。このため、通常はアクセスできないコマンドを実行することができるアクセス権限が攻撃者に与えられます。攻撃者はこの欠陥を利用して任意のコードを実行し、セキュリティやデータの整合性を侵害します。


バッファ オーバーフロー保護の設定

[バッファ オーバーフロー保護] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [バッファ オーバーフロー保護ポリシー] を選択します。

  • VirusScan コンソールからは、[バッファ オーバーフロー保護] プロパティを開きます。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブの説明

タブ 説明
バッファ オーバーフロー保護
  • バッファ オーバフロー保護を有効にします。
  • バッファ オーバーフローについて警告し保護するには、検出モードを設定します。
  • 検出発生時に [OA スキャンのメッセージ] ダイアログ ボックスを表示します。
レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。


不審なプログラムの制限

VirusScan Enterprise では、有害かまたはセキュリティ リスクをもたらす不審なプログラムからコンピュータを保護します。望ましくないプログラムの共通ポリシーを 1 つ設定できますが、ポリシーを別個に有効または無効にして、各 VirusScan Enterprise スキャナのアクションを指定できます。

目次

  • 不審なプログラムを定義する方法
  • 望ましくないプログラム ポリシーの設定


不審なプログラムを定義する方法

不審なプログラムは、インストール先コンピュータのセキュリティの状態またはプライバシ ポリシーを変えてしまう可能性がある、合法的な企業が作成したソフトウェア プログラムと定義されます。この種のソフトウェアとしては、スパイウェア、アドウェア、およびダイヤラが挙げられます。これらのプログラムは、ユーザが必要とするプログラムとともにダウンロードされる可能性があります。セキュリティ意識の高いユーザならこの種のプログラムについて認識していて、自分で削除することもあります。


望ましくないプログラム ポリシーの設定

タブの説明

設定の手順は、2 つのプロセスに分類されます。

  1. 検出および除外する不審なプログラムを定義します。
    • 現在の DAT ファイルから得られるあらかじめ定義したリストから、プログラムの全カテゴリ、またはカテゴリ内の特定プログラムを選択します。
    • 除外するプログラムを指定します。
    • 検出するユーザ定義のプログラムのリストを作成します。

  2. [不審なプログラム ポリシー] を設定したら、オンアクセス スキャナ、オンデマンド スキャナ、および電子メール スキャナで不審なプログラムの検出を有効にし、不審なプログラムが検出されたときに実行するアクションを設定します。

[不審なプログラム] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [不審なプログラム ポリシー] を選択します。

  • VirusScan コンソールからは、[不審なプログラム ポリシー] プロパティを開きます。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブ | 説明
スキャン アイテム
  • 検出する望ましくないプログラムのカテゴリを選択します。たとえば、スパイウェア、アドウェアなどです。これらのカテゴリは現在の DAT ファイルによって定義されます。
  • 除外するプログラムを指定します。
ユーザ定義のアイテム | 検出する追加の望ましくないプログラムを定義します。


検出定義のアップデート

VirusScan Enterprise ソフトウェアは、スキャン エンジンとウイルス定義 (DAT) ファイルの情報に基づいて、脅威を見分けてアクションを実行します。新しい脅威は定期的に出現します。この課題に対応するため、McAfee は、継続している調査の結果を取り込んだ、新しい DAT ファイルを毎日リリースしています。アップデート タスクでは、最新の DAT ファイル、EXTRA.DAT ファイル、スキャン エンジン、Service Pack、およびパッチが取得されます。

目次

  • アップデート方法を決定する方法
  • アップデート タスクとその機能
  • ミラー タスクとその機能
  • 自動アップデート リポジトリのしくみ
  • DAT ファイルのロールバックのしくみ


アップデート方法を決定する方法

アップデートは、さまざまな方法で実行できます。アップデート タスク、手動アップデート、ログイン スクリプトを使用することができ、また管理ツールでアップデートをスケジュールすることもできます。このセクションでは、アップデート タスクの使用法を説明します。その他の方法は、本書の範囲では扱いません。

効果的なアップデートを行うには、組織のクライアントまたはサーバの少なくとも 1 つで McAfee ダウンロード サイトからアップデートを入手する必要があります。入手したアップデート ファイルを組織全体で複製して、他のすべてのコンピュータでアクセスできるようにします。アップデート ファイルを共有サイトにコピーするプロセスを自動化して、ネットワーク全体で転送するデータ量をできる限り少なくすることが理想的です。

効果的なアップデートのために考慮する主な点は、クライアント数およびサイト数です。また、各リモート サイトのシステム数およびリモート サイトからインターネットへのアクセス方法なども考慮する場合があります。ただし、中央リポジトリを使用したアップデートの取得や、環境を最新に保つためのアップデート タスクのスケジュール設定についての基本概念は、どのような規模の組織にも適用されます。

アップデート タスクを使用すると、次のことが可能になります。

  • 都合がよい時に、管理者またはネットワーク ユーザからの介入が最も少ない状態でネットワーク全体に DAT ファイルの展開をスケジュールできます。たとえば、アップデート タスクをずらしたり、DAT ファイルのアップデートをネットワークの別々の部分で段階的または順番に導入したりすることもできます。
  • 展開管理の業務を、さまざまなサーバやドメイン コントローラ、広域ネットワークのさまざまな地域、または他のネットワーク部門に分割します。アップデートのために行う送信を基本的に内部にとどめておくことで、ネットワークのセキュリティが危険にさらされる可能性を減らすことができます。
  • 新しい DAT ファイルまたはアップグレードされたエンジン ファイルをダウンロードするために必要な待ち時間を短縮します。定期的に DAT ファイルを公開する日や製品の新しいバージョンが発表される日には、McAfee コンピュータへのアクセス量は劇的に増加します。ダウンロードが殺到する時を避けることで、中断される時間を最小限に抑えて新しいソフトウェアを配備できます。


アップデート タスクとその機能

最新の DAT ファイル、スキャン エンジン、および Service Pack とパッチを取得するには、アップデート タスクを使用します。

VirusScan Enterprise には、既定のアップデート タスクが組み込まれています。既定のタスクは、毎日午後 5:00 に 1 時間のランダム化でアップデートするようにスケジュールされています。アップデートの必要性に応じてアップデート タスクを追加で作成することもできます。

次の図は、アップデート タスクの機能のしくみを示しています。

アップデート タスクの動作

アップデート タスクを実行すると次の動作が発生します。

  • リポジトリ リストにある、最初に有効になったリポジトリ (アップデート サイト) に接続が行われます。このリポジトリが使用できない場合、次のサイトと接触し、接続が行われるまでまたはリストの末尾に到達するまで継続します。
  • 暗号化された CATALOG.Z ファイルをリポジトリからダウンロードします。ファイルには、アップデートに必要な基本データが収録されています。このデータは、使用できるファイルやアップデートを決定するために使用されます。
  • ファイルのソフトウェア バージョンとコンピュータ上のバージョンが照合されます。新しいソフトウェア アップデートがある場合は、それらがダウンロードされます。
  • リポジトリにチェックインされたアップデートは、VirusScan Enterprise に適用できること、また現在のバージョンより新しいことを確認するために検証されます。検証が済むと、VirusScan Enterprise は、次回のアップデート タスク実行時にアップデートをダウンロードします。

アップデート タスクの中断

アップデート タスクが実行中に中断されると、次の処理が行われます。

  • HTTP、UNC、またはローカル サイトからアップデートするタスクの場合には、次回アップデート タスクを開始する際に続きの部分から再開します。
  • 単一ファイルのダウンロード中に中断された場合、FTP サイトからのアップデート タスクは再開しません。ただし、複数のファイルをダウンロードするタスクが中断された場合、中断された時点でダウンロード中だったファイルの前から、タスクが再開します。

EXTRA.DAT を使用したアップデート

EXTRA.DAT ファイルは、緊急時の一時的な手段として使用できます。EXTRA.DAT は、各アップデートのリポジトリからダウンロードされます。これにより、EXTRA.DAT を編集し、パッケージとして再度チェックインした場合に、すべての VirusScan Enterprise クライアントでアップデートされた同一の EXTRA.DAT パッケージをダウンロードして使用することができます。たとえば、同じ不審なプログラムの検出機能を改良したり、他の新種の不審なプログラムに対する検出機能を追加したりすることができます。VirusScan Enterprise で使用できるのは、単一の EXTRA.DAT ファイルのみです。

ヒント: EXTRA.DAT ファイルを使用し終わったら、すべての分散リポジトリ サイトから確実にファイルが削除されるように、マスタ リポジトリからファイルを削除して複製タスクを実行してください。これにより、アップデート時に VirusScan Enterprise クライアントが EXTRA.DAT ファイルをダウンロードするのを防ぎます。デフォルトでは、毎日の DAT ファイルに新しい検出定義が追加されると、EXTRA.DAT にある新しい不審なプログラムを検出しても無視されます。


自動アップデート タスクの設定

[自動アップデート] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールから、[システム] → [システム ツリー] → [クライアント タスク] に移動します。既存のアップデート タスクを選択するか、または新しいタスクを作成するには、[新規タスク] をクリックし、[タイプ] リストから [アップデート (McAfee Agent)] を選択し、[次へ] をクリックします。

  • VirusScan コンソールから、既存のアップデート タスクを選択するか、または新しいタスクを作成するには、[タスク] → [新規アップデート タスク] を選択します。

タブでオプションを設定します。オプションの説明が必要な場合は、タブにある [?] または [ヘルプ] をクリックします。

タブの説明

タブ 説明
アップデート
  • ログ ファイルの場所または形式を指定します。
  • 新しい検出定義、新しいエンジンと DAT、サービス パックなどの使用可能なアップデート、および製品アップグレードを取得するかどうかを設定します。
  • アップデート タスクの完了後に実行する実行可能ファイルと、アップデートが成功した場合にのみ実行可能ファイルを実行するかどうかを指定します。


ミラー タスクとその機能

ミラー タスクを実行すると、リポジトリ リストに定義されたダウンロード リポジトリの中で最初にアクセス可能なサイトから、ネットワーク上のミラー サイトへアップデート ファイルが複製されます。通常、このタスクを使用するのは、McAfee ダウンロード サイトのコンテンツをローカル サーバにミラーリングする場合です。

VirusScan Enterprise ソフトウェアのアップデートは、ディレクトリ構造に依存します。サイトをミラーリングする場合は、ディレクトリ構造全体を複製することが重要です。
注: このディレクトリ構造は、以前のバージョンの VirusScan と NetShield もサポートしています。ただし、このディレクトリ構造全体が、VirusScan 4.5.1 のアップデートで使用していたのと同じ場所に複製されることが条件です。

アップデート ファイルが格納されている McAfee サイトを複製すると、ネットワーク上のコンピュータはこのミラー サイトからファイルをダウンロードできます。この方法は、ネットワーク上のコンピュータでインターネットにアクセスしなくてもアップデートできるため、実用的です。また、McAfee のインターネット サイトよりも近いサーバと通信することによりアクセス時間とダウンロード時間を短縮できるため、効率的です。


ミラー タスクの設定

[ミラー] タスクのプロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールから、[システム] → [システム ツリー] → [クライアント タスク] に移動します。既存のミラー タスクを選択するか、または新しいタスクを作成するには、[新規タスク] をクリックし、[タイプ] リストから [ミラー (McAfee Agent)] を選択し、[次へ] をクリックします。

  • VirusScan コンソールから、既存のミラー タスクを選択するか、または新しいタスクを作成するには、[タスク] → [新規ミラー タスク] を選択します。

タブでオプションを設定します。オプションの説明が必要な場合は、タブにある [?] または [ヘルプ] をクリックします。

タブの説明

タブ 説明
ミラー
  • ログ ファイルの場所または形式を指定します。
  • ミラー タスクの完了後に実行する実行可能ファイルと、ミラーが成功した場合にのみ実行可能ファイルを実行するかどうかを指定します。


自動アップデート リポジトリのしくみ

自動アップデートのリポジトリ リスト (SITELIST.XML) は、自動アップデート タスクを実行するために必要な設定情報を指定します。次に例を示します。
  • リポジトリの情報および場所
  • リポジトリの優先順位
  • プロキシ設定 (必要な場合)
  • 各リポジトリへのアクセスに必要な暗号化された資格情報

自動アップデート タスクの実行時には、リポジトリ リストにある、最初に有効になったリポジトリ (アップデート サイト) に接続が行われます。このリポジトリが使用できない場合、次のリポジトリと接触し、接続が行われるまでまたはリストの末尾に到達するまで継続します。

プロキシ サーバは、インターネット ユーザのコンピュータをインターネットから隠し、頻繁にアクセスするサイトをキャッシュしてアクセス速度を向上するためのインターネット セキュリティの一部として使用されます。ネットワークでプロキシ サーバを使用している場合、使用するプロキシ設定、プロキシ サーバのアドレス、および認証を使用するかどうかを指定できます。プロキシ情報は、自動アップデートのリポジトリ リストに保存されています。ここで構成するプロキシ設定は、リポジトリ リストにあるすべてのリポジトリに適用されます。

自動アップデート リポジトリ リストの場所はオペレーティング システムによって異なります。たとえば、Windows XP では次の場所にあります。

C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework


リポジトリ リストの設定

リポジトリ リストには、アップデートの取得元となるリポジトリが含まれます。必要な数だけリポジトリを作成し、設定します。何度も使用されるサイトもあれば、まれにしか使用されないサイトもあります。

[自動アップデート リポジトリ リスト] プロパティにアクセスするには、次の操作を実行します。

  • VirusScan コンソールから、[ツール] → [ユーザ インターフェイス オプション] を選択します。

注: この機能は ePolicy Orchestrator コンソールからは使用できません。

タブでオプションを設定します。オプションの説明が必要な場合は、タブにある [ヘルプ] をクリックします。

タブの説明

タブ | 説明
リポジトリ
  • アップデートの取得元となるリポジトリを指定します。
  • リポジトリにアクセスする順序を設定します。
プロキシ設定 | アップデート時に使用するプロキシ設定を指定します。


DAT ファイルのロールバックのしくみ

現在の DAT ファイルが破損しているか、または互換性がない場合、DAT ファイルを前回バックアップしたバージョンにロールバックできます。

DAT ファイルをアップデートすると、以前のバージョンは次の場所に保存されます。<ドライブ名>:\Program Files\Common Files\McAfee\Engine\OldDatsDAT ファイルをロールバックすると、現在の DAT ファイルが OldDats フォルダのバージョンで置き換えられ、以下のレジストリにフラグが設定されます。HKEY_LOCAL_MACHINE\SOFTWARE\McAfee\DesktopProtection\szRolledbackDATSロールバックが行われた後で以前のバージョンに戻ることはできません。次回にアップデートを実行するとき、レジストリにある DAT バージョンとアップデート リポジトリにある DAT ファイルが比較されます。新しい DAT ファイルが、レジストリ内にあるものと同じである場合、アップデートは実行されません。


DAT ファイルのロールバック

DAT ファイルを以前のバージョンにロールバックするには、次の操作を実行します。

タスク

  1. VirusScan コンソールから、[ツール] → [DAT のロールバック] を選択します。
  2. DAT のロールバックを続行するには [はい] をクリックします。
    注:

    この機能は ePolicy Orchestrator コンソールからは使用できません。

    タブでオプションを設定します。オプションの説明が必要な場合は、タブにある [ヘルプ] をクリックします。


アイテムのオンアクセス スキャン

オンアクセス スキャナを使用すると、コンピュータ上のファイルがアクセスされた時点で直ちにファイルを調べて、さまざまな脅威を常にリアルタイムで検出することができます。アクセス保護機能およびバッファ オーバフロー保護機能でもオンアクセス スキャナを使用して、アクセス ポイント違反およびバッファ オーバフロー攻撃手段を検出します。

目次

  • オンアクセス スキャンとその動作
  • スクリプト スキャンとその動作
  • スキャン ポリシーの数の決定
  • プロセスに割り当てる危険度の判断
  • 一般設定とプロセス設定の設定方法
  • 一般設定
  • プロセスの設定


オンアクセス スキャンとその動作

オンアクセス スキャナはシステムの最も深いレベル (ファイル システムのフィルタ ドライバ) と連携し、システム (システム サービス) の一部として機能して、脅威が検出されたらインターフェイスを通じて通知を配信します。

この例では、ファイルを開いたり、閉じたり、ファイルの名前を変更しようとしたときに何が行われるかについて説明します。スキャナは、処理を停止して次のアクションを実行します。

  1. スキャナは、次の条件に基づいてファイルをスキャンすべきかどうかを確認します。
    • ファイルの拡張子が設定と一致しているかどうか。
    • ファイルがキャッシュされていないか。
    • ファイルが除外されていないか。
    • ファイルが以前にスキャンされていないか。
  2. ファイルが上記のスキャン条件を満たす場合は、次のようにスキャンされます。
    • ファイルに感染が認められなければ、結果をキャッシュし、読み取り、書き込みまたは名前の変更操作を許可します。
    • ファイルで脅威が検出された場合、操作は拒否され、設定されているアクションが実行されます。
    • 結果を動作ログに記録するよう設定されていた場合には、そのとおりに行います。
  3. ファイルがスキャン要件を満たさない場合は、スキャンされません。そのファイルはキャッシュされて、操作が許可されます。


スキャンの比較 : ディスクへの書き込みとディスクからの読み取り

オンアクセス スキャナでは、ユーザがディスクに書き込みを行っているか、またはディスクから読み取りを行っているかに応じてスキャンの処理が異なります。

ファイルのディスクへの書き込み時には、次のアイテムがスキャンされます。

  • ローカル ハード ドライブに書き込まれようとしている受信ファイル。
  • ローカル ハード ドライブ上またはマップされているネットワーク ドライブ上で作成中のファイル (これには、新しいファイル、変更されたファイル、1 つのドライブから別のドライブにコピーまたは移動されているファイルが含まれます)。

ファイルのディスクからの読み取り時には、次のアイテムがスキャンされます。

  • ローカル ハード ドライブから読み取られようとしている送信ファイル。リモートのネットワーク ファイルを含めるには、[スキャン アイテム] タブで [ネットワーク ドライブ上] を選択します。
  • ローカル ハード ドライブで実行中のすべてのファイル。
  • ローカル ハード ドライブで開かれたすべてのファイル。
  • ファイルのプロパティが変更された場合は、ローカル ハード ドライブで名前を変更中のすべてのファイル。


スキャンの比較 : すべてのファイルのスキャンとデフォルトの拡張子と追加した拡張子のスキャン

オンアクセス スキャナでは、すべてのファイルをスキャンする設定と、デフォルトの拡張子と追加した拡張子をスキャンする設定のどちらかに応じて、スキャン方法が変わります。

[すべてのファイル] をスキャンすると、すべての潜在的な脅威についてすべてのファイルの種類がスキャンされます。

[デフォルトの拡張子と追加した拡張子] をスキャンすると、選択したファイルの種類に基づいて、特定のファイル リストが調べられます。
  • デフォルトの拡張子 : 指定したファイルの種類を攻撃する脅威について、そのファイルの種類のみが調べられます。たとえば、XLS ファイルをスキャンすると、マクロなど、XLS ファイルを攻撃する脅威について、XLS ファイルがスキャンされます。この場合、PE (Portable Executable) 感染のような脅威や、さらには EICAR テスト ファイルでも、XLS ファイルはスキャンされません。XLS ファイルの拡張子を変えると、新しい名前のファイルの種類に影響がある脅威について、そのファイルがスキャンされます。

  • 拡張子の追加 : [すべてのファイル] の場合と同様に、すべての潜在的な脅威について特定のファイルの種類がスキャンされます。


スクリプト スキャンとその動作

スクリプト スキャナは、正規の Windows Scripting Host コンポーネントに対するプロキシ コンポーネントとして機能します。スクリプトを停止して、スクリプトの実行前にスキャンします。

  • 問題のないスクリプトは、正規の Windows Scripting Host コンポーネントに渡されます。
  • スクリプト内に潜在的な脅威が検出された場合、そのスクリプトは実行されません。

スクリプト スキャナはスクリプトを実行しているプロセスに読み込まれるため、そのプロセスがクラッシュすると、ScriptProxy.dll および Mytilus.dll はそのプロセスのメモリ領域にあります。スクリプト スキャナは DAT ファイルとスキャン エンジンも読み込みます。これらのファイルを読み込むと、そのプロセスのメモリ フットプリントが大幅に増加します。


スキャン ポリシーの数の決定

次に示す手順で、複数のオンアクセス スキャン ポリシーを設定する必要があるかどうかを判断してください。


プロセスに割り当てる危険度の判断

複数のスキャン ポリシーが必要と判断したら、プロセスを特定しそれぞれに割り当てるリスクを判断します。

タスク

  1. 使用しているプロセスは、次の方法で判断します。Windows タスク マネージャまたは Windows パフォーマンス モニタを使用して、CPU 使用率とメモリ使用量が最も高いプロセスを簡単に確認できます。
  2. 各プロセスを担当しているプログラムを判断します。定義済み親プロセスの子プロセスのみが親のスキャン ポリシーを引き継ぐことを忘れないでください。たとえば、Microsoft Word の実行可能ファイル WINWORD.EXE を危険度高プロセスとして定義した場合は、アクセスされるすべての Microsoft Word ドキュメントが危険度高のスキャン ポリシーに従ってスキャンされます。ただし、親プロセスの Microsoft Word の起動時には、そのプロセスを起動したプロセスのポリシーに従って WINWORD.EXE ファイルがスキャンされます。
  3. 次のガイドラインに従って、各プロセスに適用するリスクを判断します。
    • 危険度低プロセス - 潜在的な脅威を拡散したり持ち込んだりする可能性が低いプロセス。たとえば、多数のファイルにアクセスするが潜在的な脅威を広げる危険度の低いプロセスに適しています。たとえば、次のように適用されます。

      バックアップ ソフトウェア

      コンパイル プロセス

    • 危険度高プロセス - 潜在的な脅威を拡散したり持ち込んだりする可能性が高いプロセス。たとえば、次のように適用されます。

      他のプロセスを起動するプロセス （Microsoft Windows エクスプローラやコマンド プロンプトなど）

      スクリプトやマクロを実行するプロセス (winword や cscript など)

      インターネットからファイルをダウンロードするプロセス (ブラウザ、インスタント メッセンジャ、メール クライアントなど)

      注: 危険度高のスキャン ポリシーは、最初はデフォルト プロセスのポリシーと同じポリシーに自動設定されます。これは、危険度高プロセスに対して詳細なスキャンが確実に実行され、最大の保護が実現されるようにするためです。デフォルト レベルのスキャンをこれよりも低いレベルにすることはお勧めできません。
    • デフォルト プロセス - 危険度低とも危険度高とも定義されていない任意のプロセス。


一般設定とプロセス設定の設定方法

オンアクセス スキャナの一般ポリシーとプロセス ポリシーは、別個に設定します。

  • 一般設定 - 一般ポリシーには、すべてのプロセスに適用するオプションが含まれます。
  • プロセス設定 - プロセス設定では、すべてのプロセスに共通に適用するスキャン ポリシーを 1 つ設定するか、またはデフォルト プロセス、危険度低プロセス、および危険度高プロセスに異なるポリシーを設定することができます。


一般設定

タブの説明

一般設定は、あらゆるプロセスのスキャンに適用され、パラメータ類を格納しています。たとえば、最大スキャン時間、スクリプトのスキャン、望ましくない脅威のリモート コンピュータからのブロック、脅威検出時のメッセージの送信、検出のレポートなどです。

[オンアクセス スキャンの全般] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールから、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] と [カテゴリ] リストの [オンアクセス スキャンの全般ポリシー] を選択します。

  • VirusScan コンソールから [オンアクセス スキャン］ のプロパティを開き、左側のペインの [一般設定] を選択します。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブ | 説明
全般
  • ブート セクタまたはフロッピー ドライブ (シャットダウン時)、あるいはその両方をスキャンします。
  • システム起動時にオンアクセス スキャンを有効にします。
  • アーカイブと全ファイルの最大スキャン時間です。
  • すでに実行中のプロセスをすべてスキャンします。
  • AntiSpyware Enterprise Module がインストールされている場合、Cookie ファイルをスキャンします。
スクリプトスキャン | スクリプトのスキャンを有効にし、除外を指定します。
ブロック
  • リモート コンピュータがこのシステムに脅威を書き込んだ場合にメッセージを送信します。送信するメッセージを指定します。
  • リモート コンピュータがこのシステムに脅威を書き込んだら、接続をブロックします。
  • 指定した時間が経過したら、接続のブロックを解除します。
  • 共有フォルダで不審なプログラムが検出されたときに接続をブロックします。
メッセージ
  • 検出発生時にローカル ユーザにメッセージのダイアログ ボックスを表示するかどうか、および表示するメッセージを指定します。
  • AntiSpyware Enterprise Module がインストールされている場合、Cookie が検出されたときにアラートが送信されます。
  • 管理者権限を持たないユーザがメッセージに基づいて実行できるアクションを設定します。
レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。
  • スキャン活動以外にログに記録する処理を指定します。


プロセスの設定

オンアクセス スキャン プロセスは、各プロセスに割り当てる危険度に基づいて設定できます。すべてのプロセスのデフォルト スキャン ポリシーを 1 つ設定したり、各プロセスに割り当てる危険度に基づいてさまざまなポリシーを設定することができます。パラメータ類には、プロセスへのリスクの割り当て、スキャン対象項目の定義、ヒューリスティックなスキャンの実行、圧縮ファイルのスキャン、検出時のアクションの実行、および不審なプログラムのスキャンなどがあります。

[デフォルト プロセス]、[危険度低プロセス]、または [危険度高プロセス] のプロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールから、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] と [カテゴリ] リストの [OA スキャンのデフォルト プロセス ポリシー]、[OA スキャンの危険度低プロセス ポリシー]、または [OA スキャンの危険度高プロセス ポリシー] を選択します。

  • VirusScan コンソールから [オンアクセス スキャン］ のプロパティを開き、左側のペインの [デフォルト プロセス]、[危険度低プロセス]、または [危険度高プロセス] を選択します。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブの説明

タブ | 説明
プロセス
  • オンアクセス スキャンのデフォルト プロセス - すべてのプロセスに共通に適用するスキャン ポリシーを 1 つ設定するのか、それともデフォルトのプロセス、危険度低プロセス、および危険度高プロセスに適用する複数のスキャン ポリシーを設定するかを選択します。
    注: スキャン ポリシーを 1 つ設定することを選択した場合、このポリシーはすべてのプロセスに適用されます。危険度低ポリシーや危険度高ポリシーの複数のスキャン ポリシーを設定することを選択した場合、このポリシーは危険度低または危険度高と定義されていないプロセスにのみ適用されます。
  • オンアクセス スキャンの危険度低プロセス - 危険度低と定義するプロセスを指定します。
  • [OA スキャンの危険度高プロセス] - 危険度高と定義するプロセスを指定します。
注: 危険度低プロセスや危険度高プロセスの個々のポリシーを設定するには、[オンアクセス スキャンのデフォルト プロセス] タブで [危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに異なるスキャン ポリシーを設定] オプションを選択する必要があります。
スキャン アイテム
  • ファイルの読み取り時、書き込み時、ネットワーク ドライブ上のファイルまたはバックアップのために開いたファイル、あるいはそ両方のファイルをスキャンするかを設定します。
  • スキャンするファイルとファイルの種類を設定します。
  • 不審なプログラム、トロイの木馬、またはマクロ ウィルスと共通点のある潜在的脅威をスキャンします。
  • アーカイブ内部をスキャンし、MIME 形式のファイルをデコードします。
  • 望ましくないプログラムのオンアクセス スキャンを有効にします。
除外 | スキャンから除外するディスク、ファイル、フォルダを指定します。
アクション
脅威が検出された場合
  • 脅威が検出されたときに最初に実行するアクションです。
  • 脅威の検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。
望ましくないプログラムが検出された場合
  • 望ましくないプログラムが検出されたときに最初に実行するアクションです。
  • 望ましくないプログラムの検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。


アイテムのオンデマンド スキャン

オンデマンド スキャナを使用すると、コンピュータの全領域について、潜在的な脅威のスキャンをいつでも必要なとき、または定期的に実行できます。オンデマンド スキャンは、オンアクセス スキャナが絶え間なく提供する防護機能を補完する目的で利用できるほか、業務に支障のない時間帯を設定して定期的なスキャンを実行したい場合に使用できます。

目次

  • オンデマンド スキャンの方法とその定義方法
  • リモート ストレージのスキャンの機能のしくみ
  • スキャンの遅延の機能
  • 不審なファイルのヒューリスティック ネットワーク チェックの仕組み
  • システム使用率の機能
  • オンデマンド スキャン タスクの設定


オンデマンド スキャンの方法とその定義方法

オンデマンド スキャナでは、次の 2 つのスキャン方法を使用します。

メモリ内プロセス スキャン

この方法では、オンデマンド スキャン タスクを実行する前に、アクティブ プロセスをすべて調べます。検出された潜在的に望ましくないプロセスは強調表示され、プロセスが停止します。つまり、オンデマンド スキャナの 1 回のパスで、1 つの潜在的に望ましくないプログラムの全インスタンスを削除できます。

インクリメンタル (再開可能) スキャン

この方法では、前回終了した場所からスキャンを再開できます。開始時刻と終了時刻、または制限時間をスケジュールしたスキャンでは、終了時刻になるとスキャンが停止します。スケジュールされた次回のスキャンでは、今回のスキャンが停止したファイルおよびフォルダ構造内のポイントからスキャンが続行されます。


リモート ストレージのスキャンの機能のしくみ

リモート ストレージのデータ ストレージは、2 つの定義済みレベルを持つ階層構造になっています。
  • 上位レベルであるローカル ストレージには、Windows 2000 Server 上でリモート ストレージを実行するコンピュータの NTFS ディスク ボリュームが含まれます。
  • 下位レベルであるリモート ストレージは、サーバ コンピュータに接続されている自動テープ ライブラリまたはスタンドアロンのテープ ドライブ上にあります。

リモート ストレージでは、ローカル ボリュームの適切なファイルがテープ ライブラリに自動的にコピーされ、ローカル ボリューム上の利用可能な空き領域が監視されます。ファイルのデータは、必要なときにすばやくアクセスできるようローカル ボリュームにキャッシュされます。リモート ストレージは、ローカル ストレージのデータを必要に応じてリモート ストレージに移します。リモート ストレージによって管理されているボリューム上のファイルは、通常どおりに開くだけでアクセスできます。そのファイルのデータがローカル ボリュームのキャッシュから削除されている場合は、リモート ストレージによってテープ ライブラリのデータが呼び出されます。


スキャンの遅延の機能

パフォーマンスを高めるために、電池容量が低い場合やプレゼンテーションの実行中にオンデマンドのスキャン タスクを遅らせることができます。また、ユーザがスケジュール スキャンを 1 ～ 24 時間の間で 1 時間刻みで遅らせるか、あるいは無期限に遅らせることを許可することもできます。ユーザ遅延 1 回の継続時間は 1 時間です。たとえば、[遅延時間] オプションを 2 に設定すると、ユーザはスキャン タスクを 2 回または 2 時間遅らせることができます。指定した最大時間が過ぎると、スキャンが続行されます。管理者がこのオプションを 0 に設定して無期限の遅延を許可した場合、ユーザーはスキャンの遅延を無期限に続けることができます。


不審なファイルのヒューリスティック ネットワーク チェックの仕組み

この機能によって、特定のマルウェアに対する最新のリアルタイム検出機能を備えた、Windows ベースの McAfee ウィルス対策製品を使用できるようになります。管理者が設定した感度レベルを使用して、VirusScan Enterprise によって保護されたクライアント システムで実行中の不審なプログラムと DLL がないかを探します。リアルタイム マルウェア防御機能は不審なプログラムを検出すると、McAfee Avert Labs によってホストされる中央のデータベース サーバに不審なファイルの指紋を含む DNS 要求を送信します。リアルタイム防御機能は、すべてのクラスのマルウェアに対して防御するのではなく、疑わしいサンプルに対してのみ保護を提供します。特定の脅威に対する保護には、サンプルがマルウェアであると McAfee Avert Labs が決定するとほぼ同時に McAfee セキュリティによってユーザを保護できるという利点があります。このリリースでは、デフォルトでこの機能は無効になっています。この機能を有効にするには、感度レベルを選択する必要があります。


システム使用率の機能

システム使用率は、オンデマンド スキャンの開始時に決定されます。CPU と IO のサンプルが最初の 30 秒間で採取され、指定した使用率レベルに基づいてスキャンが実行されます。

ここで指定するシステム使用率は、暗号化されたファイルには適用されません。暗号解読は Scan32 プロセスではなく LSASS.EXE によって実行されます。暗号化されたファイルのスキャンは CPU 使用率が非常に高いため、そのスキャン スレッドのシステム使用率の制限レベルが低い場合でもファイルは高速でスキャンされ続けます。したがって、LSASS.EXE は解読したデータを絶え間なく供給するために動作し続ける必要があります。


オンデマンド スキャン タスクの設定

VirusScan Enterprise には、デフォルトのオンデマンド スキャン タスクが含まれています。既定のタスクを使用することもできますし、新しいタスクを作成することもできます。

オンデマンド スキャン タスクにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールから、[システム] → [システム ツリー] → [クライアント タスク] に移動します。既存のオンデマンド タスクを選択するか、またはデフォルト タスクにアクセスするには、[新規タスク] をクリックし、[タイプ] リストから [オンデマンド スキャン (VirusScan Enterprise 8.7.0)] を選択し、[次へ] をクリックします。

  • VirusScan コンソールから、既存のオンデマンド スキャン タスクを選択するか、またはデフォルト タスクにアクセスするには、[フル スキャン] のプロパティを開きます。AntiSpyware Enterprise Module がインストールされている場合は、[対象のスキャン] のプロパティを開きます。新しいタスクを作成するには、[タスク] → [新規オンデマンド スキャン タスク] を選択します。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブの説明

タブ | 説明
スキャンする場所
  • スキャン対象の場所とアイテムを指定します。
  • スキャン時にサブフォルダも対象にします。
  • スキャン時にブート セクタも対象にします。
スキャン アイテム
  • スキャンするファイルとファイルの種類を設定します。
  • 望ましくないプログラムのオンデマンド スキャンを有効にします。
  • アーカイブ内部をスキャンし、MIME 形式のファイルをデコードします。
  • ストレージににバックアップしたファイルをスキャンします。
  • 不審なプログラム、トロイの木馬、またはマクロ ウィルスと共通点のある潜在的脅威をスキャンします。
除外 | スキャンから除外するディスク、ファイル、フォルダを指定します。
パフォーマンス
  • スキャンを遅らせるタイミングと期間を設定します。
  • システム使用率 (%) を指定します。
  • 不審なファイルに対するヒューリスティック ネットワーク チェックの感度レベルを設定します。
アクション
脅威が検出された場合
  • 脅威が検出されたときに最初に実行するアクションです。
  • 脅威の検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。
望ましくないプログラムが検出された場合
  • 望ましくないプログラムが検出されたときに最初に実行するアクションです。
  • 望ましくないプログラムの検出時に、最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。

プロンプト ダイアログ ボックスで許可されているアクションについて、アクションを選択します。
レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。
  • スキャン活動以外にログに記録する処理を指定します。
  • AntiSpyware Enterprise Module をインストールしている場合、Cookie が検出されたときにアラートが通知されます。
タスク オンデマンド スキャン タスクを実行する場所を指定します。
注: このタブは ePolicy Orchestrator でのみ使用できます。


配信時とオンデマンドの電子メール スキャン

電子メール スキャナは、電子メール メッセージと添付ファイルを自動的にスキャンします。

  • Microsoft Outlook の場合、電子メールは配信時にスキャンされます。Microsoft Outlook. からオンデマンド電子メール スキャンを直接呼び出すこともできます。
  • Lotus Notes では、電子メールはアクセス時にスキャンされます。

目次

  • 不審なファイルのヒューリスティック ネットワーク チェックの仕組み
  • 電子メール スキャン プロパティの設定


不審なファイルのヒューリスティック ネットワーク チェックの仕組み

この機能によって、特定のマルウェアに対する最新のリアルタイム検出機能を備えた、Windows ベースの McAfee ウィルス対策製品を使用できるようになります。管理者が設定した感度レベルを使用して、VirusScan Enterprise によって保護されたクライアント システムで実行中の不審なプログラムと DLL がないかを探します。リアルタイム マルウェア防御機能は不審なプログラムを検出すると、McAfee Avert Labs によってホストされる中央のデータベース サーバに不審なファイルの指紋を含む DNS 要求を送信します。リアルタイム防御機能は、すべてのクラスのマルウェアに対して防御するのではなく、疑わしいサンプルに対してのみ保護を提供します。特定の脅威に対する保護には、サンプルがマルウェアであると McAfee Avert Labs が決定するとほぼ同時に McAfee セキュリティによってユーザを保護できるという利点があります。このリリースでは、デフォルトでこの機能は無効になっています。この機能を有効にするには、感度を選択する必要があります。


電子メール スキャン プロパティの設定

タブの説明

[配信時電子メール スキャン] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [配信時の電子メール スキャナ ポリシー] を選択します。

  • VirusScan コンソールからは、[配信時の電子メール スキャナ] プロパティを開きます。

[オンデマンド電子メール スキャン] プロパティにアクセスするには、次の操作を実行します。

  • Microsoft Outlook からは、[ツール] → [電子メール スキャン プロパティ] を選択します。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブ 説明
スキャン アイテム
  • スキャン対象のメッセージと添付ファイルを指定します。
  • 破壊工作ソフトと共通点のある潜在的脅威をスキャンします。
  • 未知のマクロ ウイルスをスキャンします。
  • 複数の拡張子を持つ添付ファイルを検索します。
  • アーカイブ内部をスキャンし、MIME 形式のファイルをデコードします。
  • 電子メール スキャナを有効にして、望ましくないプログラムをスキャンします。
  • 電子メール本文をスキャンします。
  • 不審なファイルに対するヒューリスティック ネットワーク チェックの感度レベルを設定します。
    注: このオプションは、[配信時電子メール スキャン] でのみ使用できます。
アクション
脅威が検出された場合
  • 脅威が検出されたときに最初に実行するアクションです。
  • 最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。
望ましくないプログラムが検出された場合
  • 望ましくないプログラムが検出されたときに最初に実行するアクションです。
  • 最初のアクションが失敗した場合に実行する 2 番目のアクションを指定します。

プロンプト ダイアログ ボックスで許可されているアクションについて、アクションを選択します。
アラート
  • 脅威が埋め込まれた電子メールが検出されたら、もう 1 人のユーザに通知します。
  • ユーザがアクションの実行を求められたときに表示されるメッセージを指定します。
レポート
  • 動作ログを有効にします。
  • ログ ファイルの名前または場所を指定します。
  • ログ ファイル サイズの制限を指定します。
  • ログ ファイル形式を選択します。
  • スキャン活動以外にログに記録する処理を指定します。
Notes スキャナの設定
注: このタブは、[配信時電子メール スキャン] でのみ使用できます。

Lotus Notes に固有の設定を指定します。

  • すべてのサーバ データベースをスキャンします。
  • 指定したメールボックスのルート フォルダにあるサーバ メールボックスをスキャンします。
  • 無視する Notes アプリケーションです。


隔離ポリシーの定義

検出されたファイル、レジストリ キー、およびレジストリ値は、設定した隔離ポリシーに基づいて隔離されます。隔離したアイテムは、必要に応じて復元できます。

目次

  • 隔離ポリシーの設定とアイテムの復元


隔離ポリシーの設定とアイテムの復元

[隔離] ポリシーと [復元] プロパティにアクセスするには、以下の各方法を参照してください。

各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

ePolicy Orchestrator - 隔離ポリシー

ePolicy Orchestrator コンソールで、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [Quarantine Manager のポリシー] を選択します。

タブの説明

タブ 説明
ポリシー
  • 隔離の場所を指定します。
  • アイテムの隔離期間を設定します。

ePolicy Orchestrator — 検疫タスクからの復元

ePolicy Orchestrator コンソールで、[システム] → [システム ツリー] → [クライアント タスク] に移動し、[新しいタスク] を選択してから [タイプ] の [検疫からの復元 (VirusScan Enterprise 8.7.0)] を選択します。

タブの説明

タブ | 説明
復元 | 復元するアイテムを指定します。 注: 復元するアイテムの名前は、ログ ファイルに検出名として記載されています。
タスク | 隔離の場所にアクセス可能なユーザ アカウントを指定します。

VirusScan コンソール - Quarantine Manager のポリシー

VirusScan コンソールで、[Quarantine Manager のポリシー] プロパティを開きます。

タブの説明

タブ 説明
隔離
  • 隔離の場所を指定します。
  • アイテムの隔離期間を設定します。
マネージャ
  • 隔離したアイテムを復元、再スキャン、削除、および表示します。
    注:

    復元するアイテムの名前は、ログ ファイルに検出名として記載されています。

  • フォルスポジティブがないかどうか隔離したアイテムを確認します。


アラートおよび通知の設定

潜在的な脅威が検出されたときに通知を受け取るのは、環境を保護するために重要な点です。Alert Manager または VirusScan Enterprise ローカル アラートを使用して、検出の通知を受けることができます。

  • Alert Manager は、VirusScan Enterprise と連携してアラートやイベントをリアルタイムで処理する独立したコンポーネントです。通常の設定では、Alert Manager は中央サーバに常駐し、VirusScan Enterprise によって送信されるアラートを待機します。Alert Manager を使用して、アラートの送信場所、送信方法、およびメッセージの内容を設定します。
  • VirusScan Enterprise には、Alert Manager や、Alert Manager を必要としないその他のアラート オプションを設定するためのインターフェイスが用意されています。アラートに重大度のフィルタを適用して Alert Manager に送信されるアラートのトラフィックを制限したり、Alert Manager を必要としないローカル アラート オプションを設定したりできます。

目次

  • アラートの設定


アラートの設定

[アラート] プロパティにアクセスするには、次の操作を実行します。

  • ePolicy Orchestrator コンソールからは、[システム] → [ポリシー カタログ] に移動し、[製品] リストの [VirusScan Enterprise 8.7.0] および [カテゴリ] リストの [アラート ポリシー] を選択します。

  • VirusScan コンソールからは、[ツール] → [アラート] を選択します。

    各タブのオプションを設定します。オプションの説明を表示するには、各タブで [?] または [ヘルプ] をクリックします。

タブの説明

タブ 説明
アラート マネージャによる通知
  • アラートを生成するコンポーネントを指定します。
  • Alert Manager を設定します。
追加のアラート オプション
  • アラートに重大度のフィルタを適用します。
  • ローカル アラートを設定します。


クエリおよびダッシュボードへのアクセス

クエリおよびダッシュボードを使用すると、スキャン動作を監視することができ、検出時に実行するアクションを決定するのに役立ちます。クエリおよびダッシュボードは事前定義のものだけでなく、必要に応じて新たに作成したものも使用できます。クエリおよびダッシュボードの詳細については、ePolicy Orchestrator 製品マニュアルを参照してください。

クエリ

ePolicy Orchestrator コンソールでクエリにアクセスするには、[レポート] に移動し、[クエリ] で VSE が先頭に付くクエリまでスクロールします。

事前定義のクエリは次のとおりです。

  • VSE :過去 30 日間にわたる対応状況
  • VSE :脅威が検出されたコンピュータ (週ごと)
  • VSE :現在の DAT の適用状況
  • VSE :過去 24 時間での DAT の適用
  • VSE :現在の DAT の採用
  • VSE :検出応答サマリ
  • VSE :タグごとの検出数
  • VSE :過去 24 時間で検出されたスパイウェア
  • VSE :過去 7 日間で検出されたスパイウェア
  • VSE :過去 24 時間に検出された脅威のサマリ
  • VSE :過去 7 日間に検出された脅威のサマリ
  • VSE :重大度ごとの脅威カウント
  • VSE :週ごとに検出された脅威名 (週ごと)
  • VSE :過去 24 時間に検出された脅威
  • VSE :過去 7 日間に検出された脅威
  • VSE :過去 2 四半期に検出された脅威
  • VSE :検出された脅威 (週ごと)
  • VSE :違反の多かった上位 10 のアクセス保護ルール
  • VSE :検出されたバッファ オーバフローのトップ 10
  • VSE :最も検出の多い上位 10 コンピュータ
  • VSE :上位 10 検出脅威
  • VSE :上位 10 脅威ソース
  • VSE :脅威カテゴリごとの上位 10 脅威
  • VSE :最も検出の多い上位 10 ユーザ
  • VSE :過去 24 時間で検出された不審なプログラム
  • VSE :過去 7 日間で検出された不審なプログラム
  • VSE :バージョン 8.5 の対応状況
  • VSE :バージョン 8.7 の対応状況

ダッシュボード

ePolicy Orchestrator コンソールでダッシュボードにアクセスするには、[ダッシュボード] に移動します。

事前定義のダッシュボードは次のとおりです。
  • VSE :傾向データ
  • VSE :現在の検出


検出時の対応

検出時に実行されるアクションは、どの機能が脅威を検出するかによっていくつかあります。

目次

  • 検出時に実行されるアクション
  • システムのアクセス ポイント違反
  • バッファ オーバーフロー検出
  • 望ましくないプログラムの検出
  • オンアクセス スキャン検出
  • オンデマンド スキャン検出
  • 電子メール スキャンによる検出
  • 隔離アイテム


検出時に実行されるアクション

検出時のアクションは、DAT ファイルに定義されている検出定義によって異なります。たとえば、スキャナによるファイルの駆除ができない場合またはファイルが修復できないほど損傷している場合には、DAT ファイルでの定義に応じて、スキャナはファイルを削除するかまたは 2 番目のアクションを実行します。

スキャナによって潜在的な脅威を含むファイルへのアクセスが拒否される場合、そのファイルの保存時にファイル名に .mcm 拡張子も追加されます。


システムのアクセス ポイント違反

システムのアクセス ポイント違反が発生したとき、実行されるアクションはルールの設定によって異なります。

  • レポートするようにルールが設定されている場合、情報はログ ファイルに記録されます。

  • ブロックするようにルールが設定されている場合、アクセスがブロックされます。

ログ ファイルで、侵害されたシステムのアクセス ポイント、および侵害を検出したルールを確認した後、アクセス保護ルールを設定し、ユーザが正当なアイテムにアクセスでき、保護されたアイテムにはアクセスできないようにします。

対応として実行するアクションを決定するには、以下のシナリオを使用します。

検出の種類 シナリオ
望ましくないプロセス
  • ルールによってログ ファイルに違反がレポートされているが、違反がブロックされなかった場合、ルールに [ブロック] オプションを選択します。
  • ルールによって違反がブロックされているが、違反がログ ファイルにレポートされなかった場合、ルールに [レポート] オプションを選択します。
  • ルールによって違反がブロックされ、ログ ファイルにレポートされている場合は、アクションは不要です。
  • 検出されていない不審なプロセスを見つけた場合、ルールを編集してそのプロセスを含めます。
正当なプロセス
  • ルールによってログ ファイルに違反がレポートされているが、違反がブロックされなかった場合、ルールに [レポート] オプションを選択します。
  • ルールによって違反がブロックされ、ログ ファイルに違反がレポートされている場合、ルールを編集して正当なプロセスを除外します。


バッファ オーバーフロー検出

バッファ オーバーフローを検出したとき、次のアクションが行われます。

  • スキャナが検出をブロックします。
  • [オンアクセス スキャンのメッセージ] ダイアログ ボックスにメッセージが記録されます。ダイアログ ボックスを見てから、追加のアクションを実行するか決定します。
    • メッセージの削除 - リストのアイテムを選択し、[削除] をクリックします。
    • 除外対象の作成 - 検出されたプロセスが正当に使用しているものかフォルスポジティブの場合は、[オンアクセス スキャンのメッセージ] ダイアログ ボックスの情報を使用して除外対象を作成します。[名前] コラムにある情報を確認し、呼び出しをかけている書き込み可能メモリを所有しているプロセス名を決定します。プロセス名を利用して除外対象を作成します。
    • 分析のための Avert Labs へのサンプル送信 - スキャナで検出不要なものが検出された場合や、必要なものが検出されない場合には、サンプルを Avert Labs に送信することができます。


望ましくないプログラムの検出

オンアクセス スキャナ、オンデマンド スキャナ、電子メール スキャナは、設定した [不審なプログラム ポリシー] に基づいて不審なプログラムを検出します。不審なプログラムが検出されると、そのスキャナに対して [アクション] タブで設定したアクションが適用されます。

ログ ファイルの情報を確認してから、追加のアクションを実行するかどうかを決定します。

  • スキャンをより効率的にするためスキャン アイテムを微調整します。
  • 正当なプログラムが検出された場合は、検出対象から除外できます。
  • 望ましくないプログラムが検出されなかった場合は、そのプログラムをユーザ定義の検出リストに追加できます。
  • 分析のための Avert Labs へのサンプル送信 - スキャナで検出不要なものが検出された場合や、必要なものが検出されない場合には、サンプルを Avert Labs に送信することができます。


オンアクセス スキャン検出

検出物があった場合、次のアクションが行われます。

  • [オンアクセス スキャンのプロパティ] の [アクション] タブの設定によって、スキャナのアクションは変わります。
  • [オンアクセス スキャンのメッセージ] ダイアログ ボックスにメッセージが記録されます。

動作ログまたは [オンアクセス スキャンのメッセージ] ダイアログ ボックスの情報を確認し、どの追加のアクションを実行するか決定します。

  • スキャンをより効率的にするためスキャン アイテムを微調整します。
  • [オンアクセス スキャンのメッセージ] ダイアログ ボックス - リストの中のアイテムを右クリックし、いずれかのアクションを選択します。
    • ファイルを駆除 - 選択したメッセージに示されているファイルの駆除を試みます。
    • ファイルを削除 - 選択したメッセージに示されているファイルを削除します。削除されたファイル名はログ ファイルに記録されるので、Quarantine Manager から復元することができます。
    • すべて選択 (Ctrl+A) - リスト内のすべてのメッセージを選択します。
    • リストからメッセージを削除 (Ctrl+D) - 選択したメッセージをリストから削除します。メッセージは、リストから削除されてもログ ファイルには記録されています。
    • すべてのメッセージを削除 - すべてのメッセージをリストから削除します。メッセージは、リストから削除されてもログ ファイルには記録されています。
    • オンアクセス スキャナ ログ ファイルを開く - オンアクセス スキャナの動作ログ ファイルを開きます。このオプションは [ファイル] メニューからのみ使用できます。
    • アクセス保護ログ ファイルを開く - アクセス保護に関する動作ログ ファイルを開きます。このオプションは [ファイル] メニューからのみ使用できます。
    • 選択したメッセージに対して実行できないアクションがある場合は、そのアクションに対応するアイコン、ボタン、およびメニュー項目が無効化されます。たとえば、メッセージに示されているファイルがすでに削除されている場合には [駆除] アクションは使用できません。また、管理者がファイルの削除を禁止した場合には、[削除] アクションは使用不能となります。
    • ファイルを駆除 - DAT ファイルにクリーナがない場合や破損して修復できない場合、ファイルは駆除できません。ファイルの駆除が失敗した場合は、ファイル名に .mcm という拡張子が追加され、そのファイルへのアクセスが拒否されます。また、それについてのエントリがログ ファイルに記録されます。この場合、ファイルを削除し、安全なバックアップ コピーから復元することを推奨します。
  • 分析のための Avert Labs へのサンプル送信 - スキャナで検出不要なものが検出された場合や、必要なものが検出されない場合には、サンプルを Avert Labs に送信することができます。


オンデマンド スキャン検出

侵害の試行が検出されたとき [オンデマンド スキャンのプロパティ] の [アクション] タブの設定によって、スキャナのアクションは変わります。

ログ ファイルの情報を確認してから、追加のアクションを実行するかどうかを決定します。

  • スキャンをより効率的にするためスキャン アイテムを微調整します。
  • スキャナを [アクションを指定] するように設定した場合、[オンデマンド スキャンのプロパティ] ダイアログ ボックスからアクションを選択します。
  • 分析のための Avert Labs へのサンプル送信 - スキャナで検出不要なものが検出された場合や、必要なものが検出されない場合には、サンプルを Avert Labs に送信することができます。


電子メール スキャンによる検出

侵害の試行が検出されたときは、[配信時の電子メール スキャンのプロパティ] または [オンデマンド電子メール スキャン プロパティ] の [アクション] タブの設定に応じてスキャナのアクションが異なります。

ログ ファイルの情報を確認してから、追加のアクションを実行するかどうかを決定します。

  • スキャンをより効率的にするためスキャン アイテムを微調整します。
  • 分析のための Avert Labs へのサンプル送信 - スキャナで検出不要なものが検出された場合や、必要なものが検出されない場合には、サンプルを Avert Labs に送信することができます。


隔離アイテム

隔離ディレクトリのアイテムを確認してから、追加のアクションを実行するかどうかを決定します。

  • 復元

  • 再スキャン

  • 削除

  • フォルスポジティブの確認

  • 検出プロパティの表示

ePolicy Orchestrator コンソールからは、[隔離からの復元] クライアント タスクを使用して隔離されたアイテムにアクションを実行します。

VirusScan Enterprise コンソールからは、[Quarantine Manager のポリシー] オプションの [マネージャ] タブを使用して隔離されたアイテムにアクションを実行します。


補足情報

VirusScan Enterprise の使用法に関する補足情報については、以下のトピックを参照してください。

目次

  • ユーザ インターフェイス オプションへのアクセス
  • スキャン アイテムの追加と除外
  • タスクのスケジュール
  • コマンド ライン オプションの設定
  • リモート システムへの接続
  • 解析用の脅威サンプルの送信
  • Avert Labs 脅威ライブラリへのアクセス
  • トラブルシューティング


ユーザ インターフェイス オプションへのアクセス

スタンドアロン バージョンの VirusScan Enterprise ユーザ インターフェイスへは、さまざまな方法でアクセスできます。この情報は、ePolicy Orchestrator を使用して製品を管理する場合には適用されません。


VirusScan コンソールとその動作

VirusScan コンソールは、スタンドアロン バージョンのアプリケーション動作用のインターフェイスです。VirusScan コンソールを開くには、次のいずれかの方法を使用します。
  • [スタート] メニューをクリックし、[プログラム ] → [McAfee] → [VirusScan コンソール] を選択します。
  • システム トレイで VirusScan Enterprise シールド アイコンを右クリックし、［VirusScan コンソール］ を選択します。
VirusScan コンソールは、次のセクションに分かれています。
  • メニュー バー － メニュー バーに表示されるアイテムを使用して、タスクの作成、プロパティの設定、詳細情報へのアクセスを行います。
    • タスク － スキャンの実行や DAT ファイルのアップデートなど、タスクの作成と設定を行います。
    • 編集 － 選択したタスクのコピー、貼り付け、名前の変更を行います。
    • 表示 － ツール バーやステータス バーの表示、内容の更新を行います。
    • ツール － ユーザのためのインターフェイス オプションの設定、ユーザ インターフェイス セキュリティのロック/ロック解除、アラートの設定、イベント ビューアへのアクセス、リモート コンソールへの接続 (管理者権限がある場合)、リポジトリ リストのインポート/編集、DAT ファイルのロールバックを行います。
    • ヘルプ － オンライン ヘルプ トピック、Avert Labs Web サイトの脅威ライブラリ、サンプル送信の Web サイト、テクニカル サポートの Web サイトにアクセスします。インストールした製品の修復を行うこともできます。また、［バージョン情報］ ダイアログ ボックスには、著作権情報、インストールされている製品のバージョン、ライセンス タイプ、定義ファイル、スキャン エンジン、外部ドライバ、パッチの情報が表示されます。
    注: メニューの各アイテムには、関連付けられたショートカット キーがあります。各アイテムのショートカット キーには下線が引かれています。メニューへのアクセスにキーボードを使用する場合を除き (F10 または ALT)、これらのショートカット キーが使用できないオペレーティング システムもあります。
  • ツールバー － アイコンをクリックして、これらのよく使用するコマンドにアクセスします。
    • 選択したタスクのプロパティを表示します。
    • 選択したタスクを開始します。
    • 選択したタスクを停止します。
    • 選択したタスクをコピーします。
    • 選択したタスクを貼り付けます。
    • 選択したタスクを削除します。
    • アラートのプロパティを設定します。
    • イベント ビューアを起動します。
    • Avert Labs の Web サイトの情報ライブラリにアクセスします。
    • 管理者権限がある場合、リモート コンピュータに接続します。
    • 新しいオンデマンド スキャンを作成します。
  • タスク リスト － デフォルトのタスクと、新規作成したタスクが表示されます。各タスクの状態と、最終結果も表示されます。
  • ステータス バー － 現在のアクティビティの状態が表示されます。


右クリック機能の使用

右クリック機能を使用すると、新規タスクの作成、タスク統計およびログの表示、タスク プロパティ ページの表示、特定ファイルまたはフォルダのスキャン、またはタスクの即時アップデートなど、使用頻度の高いアクションにすばやくアクセスすることができます。

機能の説明

場所 説明 例
コンソール VirusScan コンソールを右クリックすると、右クリック機能が表示されます。タスクをタスク リストで選択しているかどうか、およびどのタスクを選択するかにより、機能は異なります。
  • コンソールでタスクを右クリックしてプロパティを表示します。どのタスクを選択するかにより、タスクの開始、停止、有効無効の切り替え、および統計や動作ログの表示ができます。タスクの名前の変更やタスクの削除ができる場合もあります。
  • 新しいスキャンまたはアップデート タスクを作成するには、コンソールの空白領域を右クリックします。
Windows エクスプローラ 選択したファイルまたはフォルダを右クリックすると、そのアイテムの [フル スキャン] を直ちに実行できます。次のスキャン アクションを選択できます。
  • 駆除 — 検出されたアイテムを報告し、駆除します。
  • 続行 — 検出内容を報告し、スキャンを続行します。

脅威にさらされている疑いがあるファイルやフォルダに対して即時スキャンを実行します。

スキャンを開始すると、すべてのスキャン設定が有効な状態で、オンデマンド スキャナが直接呼び出されます。アクション オプションを選択します。それ以外のスキャン設定はカスタマイズできません。
システム トレイ VirusScan Enterprise シールド アイコンを右クリックすると、メニュー アイテムが表示されます。
  • VirusScan コンソールを開きます。
  • OA スキャナを無効または有効にします。
  • OA スキャナのプロパティを開きます。
  • OA スキャンの統計やメッセージを表示します。
  • 1 度だけ実行する設定可能オンデマンド スキャンを作成します。
  • 即時アップデート タスクを実行します。
  • [バージョン情報］ ダイアログ ボックスを開きます。


システム トレイ アイコンとその動作

VirusScan Enterprise をインストールすると、シールド アイコンが、Windows システム トレイに表示されます。この機能はインストール中に設定することができます。

次の事項に注意します。
  • OA スキャナがアクセス保護違反を検出するとアイコンが変化します。リセットしないかぎり、アイコンの周囲の赤い枠は、30 分間表示されます。詳細については、「システムのアクセス ポイントの保護」セクションの「アクセス違反とVirusScan Enterprise の対応」を参照してください。
  • アイコンをダブルクリックすると、次のメニュー オプションが表示されます。
    • VirusScan コンソール ‐ VirusScan コンソールを開きます。
    • オンアクセス スキャンを無効化 ‐ 有効と無効を切り替えます。
      注: アクセス保護、バッファ オーバーフロー保護、およびスクリプト スキャンの各機能は、OA スキャナを使用します。OA スキャナを無効にすると、アクセス違反、バッファ オーバーフロー、および不審なスクリプトの実行から保護されなくなります。
    • オンアクセス スキャンのプロパティ ‐ オンアクセス スキャナのプロパティ ページを開きます。
    • オンアクセス スキャン統計 ‐ オンアクセス スキャナ統計を表示します。ここから、オンアクセス スキャナの有効無効の切り替え、およびオンアクセス スキャナのプロパティ ページを開くことができます。
    • OA スキャナ メッセージ - OA スキャナ メッセージを表示します。ここからリストのアイテムに対してアクションを実行できます。
    • オンデマンド スキャン - 未保存のタスクのオンデマンド スキャン タスク プロパティ ページを開きます。ここから 1 度だけ実行するオンデマンド スキャン タスクを作成します。
    • 今すぐ更新 - 即時自動アップデート タスクを実行します。
    • VirusScan Enterprise のバージョン情報 - 製品、ライセンス、またインストールされているスキャン エンジン、検出定義ファイル、外部ドライバ (extra.dat)、およびパッチのバージョンを表示します。


[スタート] メニューと VirusScan Enterprise との連携

次のメニュー アイテムにアクセスするには、Windows の [スタート] メニューをクリックし、[プログラム] → [McAfee] を選択します。
  • VirusScan コンソール ‐ VirusScan コンソールを開きます。
  • オンアクセス スキャン ‐ オンアクセス スキャンのプロパティ ページを開きます。
  • オンデマンド スキャン - オンデマンド スキャンのプロパティ ページを開きます。ここから 1 度だけ実行する未保存の [フル スキャン] を設定し実行します。


コマンド ラインを使用した VirusScan Enterprise の設定

コマンド ラインを使用して、コマンド プロンプトから動作を実行します。詳細については、「コマンド ライン オプション」を参照してください。


スキャン アイテムの追加と除外

検出設定を実行する場合、VirusScan Enterprise の各スキャナでスキャン対象拡張子のリストを微調整できます。


スキャン アイテムの指定

スキャン機能は、デフォルトのリストにスキャン アイテムを追加したり、スキャン対象を表す拡張子のリストを作成することで微調整できます。

オプションの定義

オプション 定義
スキャンするファイルの種類
  • デフォルトと追加のファイル拡張子 - 追加のファイル拡張子と、すべてのファイルをスキャンしてマクロの有無を確認するかどうかを指定します。スキャナに追加できるファイル拡張子の最大数は 1,000 件です。
  • 指定したファイルの種類のみ - スキャン対象を表す拡張子のリストを作成します。スキャナに追加できるファイル拡張子の最大数は 1,000 件です。


除外対象の指定

スキャン操作から除外するファイル、フォルダ、およびドライブを指定してください。以前に指定した除外対象を削除することもできます。

オプションの定義

オプション 定義
スキャン対象外 除外の種類を選択します。
  • パターンを指定して除外 - パターンの指定、およびサブフォルダを含めるかどうかの指定を行います。
  • ファイルの種類を指定して除外 - ファイルの種類を指定します。
  • ファイルの保存期間を指定して除外 - アクセス タイプの指定、およびファイルが作成されてからの経過日数の指定を行います。
  • Windows ファイル保護機能で保護されているファイル - Windows ファイル保護機能のステータスを持つファイルを除外します。


ワイルドカードを使用したスキャン アイテムの指定

ワイルドカードを使用してスキャン アイテムを指定または除外する場合の注意点は次のとおりです。

  • 有効なワイルドカードは、1 文字を除外する疑問符 (?) と複数文字を除外するアスタリスク (*) です。
  • ワイルドカードは、パスの円記号 (\) の前で使用できます。たとえば、C:\ABC\*\XYZ は C:\ABC\DEF\XYZ と一致します。

  • 疑問符 (?) を含めて指定した場合は、それと同じ文字数のファイル名またはフォルダ名が除外対象として扱われます。たとえば、W?? と指定した場合、WWW は除外されますが、WW や WWWW は除外されません。

  • 構文上、2 重のアスタリスク (**) を含めることもできます。これはゼロ個以上の任意の文字 (円記号を含む)を意味します。これにより、複数の深さで除外対象を指定できます。たとえば、C:\ABC\**\XYZ と指定した場合、C:\ABC\DEF\XYZ や C:\ABC\DEF\DEF\XYZ などが除外対象となります。


タスクのスケジュール

オプションとして、オンデマンド、自動アップデート、およびミラーの各タスクをスケジュールすることができ、特定の日時または間隔での実行が可能ｊです。


タスク スケジュールの設定

指定時または定期的に実行するタスクを設定します。

注: このタスクをスケジュールするには、管理者権限が必要です。管理者権限があると、スケジュール タスクのレジストリ キーへの書き込みアクセスが可能です。

タスクのスケジュールを設定するには、タスクのプロパティ ダイアログ ボックスで [スケジュール] ボタンをクリックします。

タブの説明

タブ 説明
タスク
  • 指定された回数実行するにはスケジュール タスクを有効にします。
  • 指定された時間と分の間実行するとタスクを終了します。
  • ユーザ名、ドメイン、パスワードなどのユーザ アカウント設定を指定します。
スケジュール

スケジュールの頻度と関連する設定を指定します。


コマンド ライン オプションの設定

VirusScan Enterprise は、コマンド ラインからインストール、設定、および実行できます。インストール オプションについては、『VirusScan Enterprise インストール ガイド』を参照してください。このセクションでは、オンデマンド スキャンおよびタスクのアップデートを実行するためのオプションについて説明します。


オンデマンド スキャンのコマンド ライン オプションの設定

オンデマンド スキャナでは、SCAN32.EXE を使用して脅威を検出します。

SCAN32 構文では、プロパティと値を分割してはいけないこと以外、要素に特定の順序を必要としません。この構文は次の要素で構成されます。
  • ファイル名 — 実行可能ファイルの名前 : SCAN32.EXE
  • オプション — オプションの前にはスラッシュ (/) が付き、大文字小文字の区別はありません。
例 : SCAN32 PROPERTY=VALUE [,VALUE] [/オプション]

オンデマンド スキャン オプションの定義

コマンド ライン オプション | 定義
ALL | 対象フォルダ内のすべてのファイルをスキャンします。
ALLOLE | デフォルト ファイルとすべての Microsoft Office ドキュメントをスキャンします。
ALWAYSEXIT | スキャンでエラーが発生または失敗しても、オンデマンド スキャンを強制終了します。
APPLYNVP | 不審なプログラム ポリシーで定義された、潜在的に不審なプログラムをスキャンします。
ARCHIVE | .ZIP、.CAP、.LZH、.UUE ファイルなどのアーカイブ ファイルをスキャンします。
AUTOEXIT | 非対話型スキャン終了時にオンデマンド スキャナを終了します。
CLEAN | 潜在的に不審なプログラムを発見した場合、検出した対象ファイルを駆除します。
CLEANA | 不審なプログラムを発見した場合、検出したファイルを駆除します。
CONTINUE | 潜在的に不審なプログラムを検出した後にスキャンを続行します。
CONTINUE2 | 潜在的に不審なプログラムを検出し、最初のアクションに失敗した後にスキャンを続行します。
CONTINUEA | 不審なプログラムを検出した後にスキャンを続行します。
CONTINUEA2 | 不審なプログラムを検出し、最初のアクションに失敗した後にスキャンを続行します。
DEFEXT | パラメータとして指定するファイル拡張子を、スキャンに含まれる選択したファイルの種類のリストに追加します。
DELETE | 潜在的に不審なプログラムを発見した場合、検出したファイルを削除します。
DELETE2 | 潜在的に不審なプログラムを発見し、最初のアクションに失敗した場合に、検出したファイルを削除します。
DELETEA | 不審なプログラムが検出された場合にファイルを削除します。
DELETEA2 | 潜在的に不審なプログラムを検出し、最初のアクションに失敗した場合に、ファイルを削除します。
EDIT | スキャン プロパティのダイアログ ボックスを表示します。
EXT | スキャンに含まれる選択したファイルの種類のリストにある拡張子を、この引数の後にパラメータとして追加するファイル拡張子と置き換えます。
LOG | 以前に指定したログ ファイルに検出レポートのログを記録します。
LOGFORMAT <値> | ログ ファイルに指定した形式を使用します。有効な値は、ANSI、UTF8、または UTF16 です。
LOGSETTINGS | スキャンの構成設定をログに記録します。
LOGSUMMARY | スキャン結果のサマリをログに記録します。
LOGUSER | スキャンを実行するユーザについての識別情報をログに記録します。
MHEUR | マクロ ウイルスのヒューリスティック検出を有効にします。
MIME | mime (多目的インターネット メール拡張仕様) でエンコードされたファイルで潜在的に不審なプログラムを検出します。
NOESTIMATE | ファイルのスキャンを開始する前にスキャン サイズを計算しません。進行状況を示す棒グラフは表示されません。
PHEUR | マクロ ウイルス以外のヒューリスティック検出を有効にします。
PRIORITY | 他の CPU 処理と相対してスキャンの優先順位を設定します。補足的な数値パラメータが必要です。値 1 を割り当てると、他のすべての CPU 処理が優先します。値 5 を割り当てると、スキャンが最優先になります。
PROMPT | 潜在的に不審なプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。
PROMPT2 | 潜在的に不審なプログラムを検出し、最初のアクションに失敗した場合に、ユーザにアクションを促すメッセージを表示します。
PROMPTA | 不審なプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。
PROMPTA | 不審なプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。
PROMPTA | 不審なプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。
PROMPTA | 不審なプログラムを検出した場合、ユーザにアクションを促すメッセージを表示します。
PROMPTA2 | 不審なプログラムを検出し、最初のアクションに失敗した場合に、ユーザにアクションを促すメッセージを表示します。
RPTSIZE | アラート ログのサイズを MB 単位で設定します。
START | スキャンを実行します。プロパティ ダイアログ ボックスは表示しません。
TASK | VirusScan コンソールで指定されたオンデマンド スキャン タスクを開始します。次の場所にあるレジストリに記録された指定タスク ID を指定する追加パラメータが必要です。hkey_local_machine_\software\McAfee\Desktop\Protection\Tasks
UINONE | ユーザ インターフェイス ダイアログを表示せずにスキャナを起動します。


アップデート タスク コマンド ライン オプションの設定

VirusScan Enterprise では、MCUPDATE.EXE を使用してタスクのアップデートを実行します。

MCUPDATE 構文では、プロパティと値を分割してはいけないこと以外、要素に特定の順序を必要としません。構文は次の要素で構成されます。
  • ファイル名 — 実行可能ファイルの名前 : MCUPDATE.EXE
  • オプション — オプションの前にはスラッシュ (/) が付き、大文字小文字の区別はありません。
例 : MCUPDATE [/<種類> [/TASK <guid>]] [/オプション]

/TASK の節はオプションですが、使用する場合は、アップデート タスク ID (guid) も指定する必要があります。選択するタスク ID は、アップデート タスクまたは DAT のロールバック タスクの ID である必要があります。スキャン ID は選択しないでください。タスク ID を指定しない場合は、デフォルトのアップデート タスクが使用されます。タスク ID は次の場所にあります。hkey_local_machine\SOFTWARE\McAfee\DesktopProtection\Tasks\

/OPTION の節は必須ではありません。サイレント アップデート タスクを実行するには、/QUIET を使用します。
注: /QUIET オプションを DAT のロールバック タスクで使用することはできません。次の例では、サイレント アップデート タスクを実行します。MCUPDATE [/UPDATE] [/QUIET]

アップデート タスク オプションの定義

コマンド ライン オプション | 定義
ROLLBACKDATS | 現在の DAT ファイルを、最後にバックアップしたバージョンにロールバックします。
UPDATE | DAT ファイル、スキャン エンジン、製品、または extra.dat のアップデートを実行します。
/TASK | VirusScan コンソールで指定された自動アップデートまたは DAT のロールバック タスクを開始します。次の場所にあるレジストリに記録されたタスク ID を指定する追加のパラメータが必要です。 hkey_local_machine\software\McAfee\DesktopProtection\Tasks
/QUIET | タスクをサイレントに実行します。


リモート システムへの接続

VirusScan Enterprise がインストールされた状態でリモート システムに接続して、スキャン タスクまたはアップデート タスクの変更やスケジュール設定、リモート システム上のオンアクセス スキャナの有効化/無効化などの操作ができます。
注: 管理者権限のないユーザがリモート システムへの接続を試行すると、「必要な権限がありません。アクセスが拒否されました。」というメッセージが表示されます。

[VirusScan リモート コンソール] を起動すると、接続しているシステムの名前がコンソールのタイトル バーに表示されます。ネットワーク上のシステムに接続していない場合には、タイトル バーにローカル システム名は表示されません。リモート コンソールからタスクのプロパティ ダイアログ ボックスを開くと、プロパティ ダイアログ ボックスのタイトル バーにシステム名が表示されます。

複数のリモート コンソールを開くことができます。[リモート コンピュータに接続］ダイアログ ボックスを閉じると、リモート システムとの接続も切断されます。


VirusScan Enterprise がインストールされている場合のリモート システムへのアクセス

VirusScan Enterprise がインストールされている場合にリモート システムに接続するには、次の操作を実行します。

タスク

VirusScan コンソールの [ツール] メニューから、[リモート コンソールを開く] を選択します。

  1. [コンピュータに接続］ で、管理するシステム名を入力し、リストからシステムを選択するか、［参照］ をクリックしてネットワーク上のシステムを指定します。
    注: リモート タスク用にファイルまたはフォルダのパス名を設定するときに環境変数を使用する場合は、リモート システム上にその環境変数が存在することを確認してください。VirusScan コンソールでは、リモート システム上の環境変数を確認することはできません。
  2. [OK］ をクリックして対象のシステムへの接続を試行します。 リモート システムに接続すると、次のことが起こります。
    • システム名を反映してタイトル バーが変わります。
    • コンソールはリモート システムのレジストリを読み込み、リモート システムのタスクを表示します。リモート システム用のタスクを追加、削除、再設定することができます。


解析用の脅威サンプルの送信

現在の DAT ファイルでは検出されていない潜在的な脅威を発見した場合、そのサンプルを WebImmune を通して McAfee Avert Labs に送信できます。Avert Labs ではサンプルを解析し、DAT ファイルに含めるかどうか検討します。

スキャナで検出する必要がないと思われるものを検出した場合も、そのサンプルを WebImmune を通して Avert Labs に送信できます。AVERT ではサンプルを解析し、DAT ファイルから除外するかどうかを検討します。

WebImmune を通して Avert Labs にサンプルを送信する際には、Web サイトに直接アクセスするか、電子メールまたは郵便を利用できます。

WebImmune

VirusScan コンソールから、[ヘルプ] → [サンプルの送信] を選択して Web サイトにアクセスします。

Web サイトは次の場所にあります。https://www.webimmune.net/default.asp

  1. フリー アカウントにログオンするか、またはフリー アカウントを作成します。
  2. 解析を依頼するファイルを Avert Labs の自動システムに直接アップロードできます。さらに調査が必要な場合、アイテムは Avert Labs の分析担当者にエスカレーションされます。

電子メール

解析を依頼する電子メールを Avert Labs の自動システムに直接送信できます。さらに調査が必要な場合、アイテムは Avert Labs の分析担当者にエスカレーションされます。

グローバル電子メール アドレスは virus_research@avertlabs.com です。
注: WebImmune の Web サイトから、その他のリージョナル アドレスを取得することもできます。

郵便

WebImmune の Web サイトから送付先情報を取得してください。
注: この方法は、サンプル解析の所要時間が最も長くなるため、あまりお勧めできません。


Avert Labs 脅威ライブラリへのアクセス

VirusScan コンソールから Avert Labs 脅威ライブラリにアクセスするには、[ヘルプ] メニューから [McAfee Avert Labs 脅威ライブラリ] を選択します。


トラブルシューティング

このセクションには、VirusScan Enterprise 製品のトラブルシューティング情報が含まれています。


製品インストールの修復

VirusScan Enterprise 修復インストール ユーティリティを使用すると、アプリケーションのデフォルトのインストール設定を復元したり、すべてのアプリケーション ファイルを再インストールしたりすることができます。

[修復インストール] ユーティリティにアクセスするには、VirusScan コンソールから [ヘルプ] → [修復インストール] を選択します。
注: この機能は ePolicy Orchestrator コンソールからは使用できません。

オプションの定義

オプション | 定義
すべての設定をデフォルトに戻す | VirusScan Enterprise のデフォルトのインストール設定を復元します。 注意: インストール後に変更した設定は無効になります。
アプリケーション ファイルをすべて再インストールする | VirusScan Enterprise のアプリケーション ファイルを再インストールします。 注意: ホットフィックス、パッチ、および Service Pack は、上書きされることがあります。


よく寄せられる質問

このセクションには、よくある質問の形式でトラブルシューティング情報が記載されています。

インストール

  • 質問 : サイレント インストール方式でソフトウェアをインストールましたが、Windows システム トレイに VirusScan Enterprise のアイコンがありません。

    回答 : システムを再起動するまでシステム トレイにアイコン シールドは表示されません。ただし、アイコンが表示されていなくても VirusScan Enterprise は実行されており、システムは保護されています。これは、次のレジストリ キーを調べて確認します。HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ ShStatEXE="C:\Program Files\McAfee\VirusScan Enterprise\SHSTAT.EXE"/STANDALONE.

  • 質問 : ネットワーク上で独自の設定を構成できるユーザと、構成できないユーザがいるのはなぜですか。

    回答 : 管理者が、タスクをパスワードで保護するようにユーザ インターフェイスを設定している可能性があります。その場合、ユーザは設定を変更できません。さらに、使用する Windows オペレーティング システムが異なっていると、ユーザの権限も異なります。ユーザの権限については、使用している Microsoft Windows のドキュメントを参照してください。

不審なプログラム

  • 質問 : 不審なプログラムがあるのですが、VirusScan Enterprise では検出されません。

    回答 : まだ正式リリース前のテスト中ですが、最新のベータ版 DAT ファイルを次の Web サイトからダウンロードします。http://vil.nai.com/vil/virus-4d.asp

ブロックされたアプリケーション

  • 質問 : VirusScan Enterprise をインストールしたら、アプリケーションの 1 つが動作しなくなりました。

    回答 : そのアプリケーションはアクセス保護ルールによってブロックされている可能性があります。
    1. アクセス保護ログ ファイルを調べて、そのアプリケーションがルールによってブロックされたかどうかを確認してください。
    2. アプリケーションがログに記載されていることがわかったら、そのアプリケーションを除外アイテムとしてルールに入力するか、ルールを無効にすることができます。詳細については、「システムのアクセス ポイントの保護」を参照してください。

Cookie の検出

  • 質問 : オンデマンド スキャンの動作ログで Cookie の検出を確認すると、検出のファイル名がすべて 00000000.ie となっていました。他のアプリケーションでは Cookie の検出ごとに個別のファイル名や数字が増えるファイル名が割り当てられるのに、VirusScan Enterprise では、オンデマンド スキャンによる Cookie の検出すべてに同じファイル名が割り当てられるのはなぜですか。

    回答 : VirusScan Enterprise では、オンデマンド スキャンで Cookie の検出が行われてアクションが実行される方法のために、それぞれの Cookie の検出に同じファイル名が割り当てられます。この動作が適用されるのは、オンデマンド スキャンで検出された Cookie だけです。1 つの Cookie ファイルには、多数の Cookie が含まれている可能性があります。スキャン エンジンは Cookie ファイルをアーカイブとして扱い、ファイルの先頭からのオフセットとして、(ゼロから始まる) 1 つの値を割り当てます。スキャナでは、スキャン エンジンを使用して Cookie の検出が行われ、スキャンを続行する前に、検出された Cookie ごとにアクションが実行されるため、それぞれの検出に対して値がゼロから付け直されます。この結果、すべての検出にファイル名として 00000000.ie が割り当てられます。他の製品は、すべての Cookie を検出し、それぞれに個別のファイル名または数字が増えるファイル名を割り当ててから、各検出に対してアクションを実行します。

全般

  • 質問 : システム トレイの VirusScan Enterprise アイコンが無効にされているようです。

    回答 : VirusScan Enterprise アイコンの上に赤い円と線がある場合は、OA スキャナが無効になっていることを意味します。一般的な原因と解決策を次に示します。どの方法でも問題が解決されない場合は、テクニカル サポートに問い合わせてください。
    1. OA スキャナが有効になっていることを確認します。システム トレイの VirusScan Enterprise アイコンを右クリックします。OA スキャナが無効になっている場合は、[OA スキャンの有効化] をクリックします。
    2. McShield サービスが実行されていることを確認します。
      • コントロール パネルの [サービス] から手動でサービスを開始します。
      • [スタート] メニューから [ファイル名を指定して実行] を選択し、「Net Start McShield」と入力します。
      • コントロール パネルの [サービス] で、サービスが自動的に開始されるように設定します。

  • 質問 : CATALOG.Z をダウンロードできないというエラーが表示されます。

    回答 : このエラーにはさまざまな原因が考えられます。問題の原因を特定するのに役立つヒントをいくつか示します。
    • アップデートのために既定の McAfee ダウンロード サイトを使用している場合は、Web ブラウザから CATALOG.Z ファイルをダウンロードできるかどうか確認します。次の Web サイトからファイルをダウンロードできるかどうか試してみてください。http://update.nai.com/Products/CommonUpdater/catalog.z
    • ファイルをダウンロードできない場合でも、ファイルが見られる (言い換えれば、ファイルのダウンロードがブラウザによって許可されない) 場合は、プロキシに関する問題があります。ネットワーク管理者に相談してください。
    • ファイルをダウンロードできる場合は、VirusScan Enterprise でもダウンロードできるはずです。インストールされている VirusScan Enterprise のトラブルシューティングについて、テクニカル サポートに問い合わせてください。

  • 質問 : HTTP ダウンロード サイトの場所はどこですか。

    回答 :
    • McAfee ダウンロード サイトの場所は次のとおりです。http://www.mcafeesecurity.com/us/downloads/updates/default.asp
    • 最新のアップデートが含まれる CATALOG.Z ファイルは、次の Web サイトからダウンロードできます。http://update.nai.com/Products/CommonUpdater/catalog.z

  • 質問 : FTP ダウンロード サイトの場所はどこですか。

    回答 :
    • FTP ダウンロード サイトの場所は次のとおりです。ftp://ftp.mcafee.com/pub/antivirus/datfiles/4.x
    • 最新のアップデートが含まれる CATALOG.Z ファイルは、次のサイトからダウンロードできます。ftp://ftp.mcafee.com/CommonUpdater/catalog.z

  • 質問 : [アクションを指定] を選択していて、不審なプログラムが実際に検出された場合は、どのアクション ([駆除] または [削除]) を選択すべきですか。

    回答 : 一般的には、検出されたファイルをどうするか自信がない場合は、[ウイルスを駆除] を選択することをお勧めします。OA スキャナまたはオンデマンド スキャナは、アイテムが駆除または削除される前に、それらのアイテムを自動的に隔離ディレクトリにバックアップします。


[アクセス保護] タブ

オプションの定義

アクセス保護ルールを設定して、McAfee のプロセスが終了されることを防止します。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator 経由でのみ使用できます。
アクセス保護設定
  • [アクセス保護の有効化] - アクセス保護機能を有効にします。
  • [McAfee サービスの停止を防止] - デバッグ特権のないユーザによる McAfee プロセスの終了を防止します。

    このオプションを選択しても、プログラムのデバッグ特権があるユーザは McAfee プロセスを終了できます。

    Windows XP および Windows Server 2003 の場合、管理者にはデフォルトでプログラムのデバッグ特権が与えられています。ユーザが McAfee プロセスを終了できないようにするには、ユーザのアクセス許可からこれらの特権を削除します。
アクセス保護のルール

[カテゴリ] - カテゴリをクリックし、そのカテゴリのルールを表示します。ルールは、次のカテゴリに整理されます。

  • ウイルス対策標準保護
  • ウイルス対策最大保護
  • ウイルス対策アウトブレーク コントロール
  • 一般標準プロテクト
  • 一般最大プロテクト
  • 仮想マシン保護
  • ユーザ定義ルール

AntiSpyware Enterprise Module 8.7 をインストールしている場合は、次のカテゴリもあります。

  • スパイウェア対策標準保護
  • スパイウェア対策最大保護

詳細については、「アクセス保護ルールを定義する方法」を参照してください。

ブロック/レポート/ルール - 次のルールを設定します。

  • ブロック - [ルールの詳細] で指定されたプロセスをブロックします。[ブロック] チェック ボックスをオンにしてルールを有効にするか、オフにしてルールを無効にします。

    注:

    ログ記録を行わずにアクセスの試みをブロックするには、[ブロック] オプションを選択し、[レポート] オプションは選択しないでください。

  • レポート ‐アクセス保護の侵害が試みられた場合のレポートを有効にします。侵害の試行が検出された場合、情報は動作ログに記録されます。
    注:

    アクセスの試みをブロックせずに、警告の受信だけを行うには、[レポート] オプションを選択し、[ブロック] オプションは選択しないでください。これは、ルールの影響が完全に判明していない場合に便利です。ログまたはレポートを短時間監視し、アクセスをブロックするかどうか判断します。

  • ルール - アクセス保護のルールを使用して、望ましくない変更からコンピュータを保護します。ルールはカテゴリ別に整理されます。まずカテゴリを選択し、次にルールを選択します。詳細については、「ウイルス対策ルールと共通ルールの設定」と「ユーザ定義ルールの設定」を参照してください。

    新規 - 新規のユーザ定義ルールを作成します。詳細については、「ユーザ定義ルールの設定」を参照してください。

    編集 - 既存のルールを変更します。

    削除 - 既存のユーザ定義ルールを削除します。
    注:

    ユーザ定義ルールのみ削除できます。他のルールは編集または無効化できますが、削除はできません。ルールを無効にするには、[ブロック] オプションと [レポート] オプションの選択を解除します。


[追加のアラート オプション] タブ

オプションの定義

フィルタとローカル アラートのオプションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
重大度フィルタ 以下のフィルタ オプションから選択します。
  • アラートをフィルタしない - すべてのアラートを送信します。
  • 情報アラートは送信しない - 重要度 1 未満のアラートは送信しません。
  • 情報および警告アラートは送信しない - 重要度 2 未満の情報アラートと警告アラートは送信しません。
  • 情報、警告、および低度のアラートを抑制 - 重要度 3 未満の情報アラート、警告アラート、危険度低アラートは送信しません。
  • 緊急事態アラート以外は送信しない - 重要度 4 未満のアラートは送信しません。
  • どのアラートも送信しない - すべてのアラートを送信しません。
ローカル アラート
  • ローカル アプリケーションのイベント ログに記録する - 情報をローカル アプリケーションのイベント ログに記録します。
  • SNMP サービスを使用して SNMP トラップを送信する - SNMP を使用している場合、SNMP トラップ アラートを送信できます。
注:

ローカル アラート オプションに Alert Manager は必要ありません。


[アラート] タブ

オプションの定義

アラートを生成するコンポーネントを選択し、Alert Manager を設定します (インストールされている場合)。

詳細については、『Alert Manager 4.7.1 製品ガイド』を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
アラートを生成するコンポーネント
  • オンアクセス スキャン - オンアクセス スキャナが脅威を検出したら、アラートを生成します。
  • オンデマンド スキャンとスケジュール スキャン - オンデマンド スキャン タスクが脅威を検出したら、アラートを生成します。
  • 電子メール スキャン - 電子メールスキャナが脅威を検出したら、アラートを生成します。
  • 自動アップデート - アップデート タスクが脅威を検出したら、アラートを生成します。
  • アクセス保護 - アクセス保護が脅威を検出したら、アラートを生成します。
Alert Manager のオプション
  • アラート通知を無効にする - 侵入が検出されたときにアラートを生成しません。
  • 集中管理アラートを有効にする - 侵入が検出されたときに集中管理アラートを使用してユーザに通知します。
  • アラート マネージャのアラート通知を有効にする - 侵入が検出されたときに Alert Manager を使用してユーザに通知します。このオプションを選択し、アラートを受信する Alert Manager サーバの場所へのパスを入力します。
    • Active Directory の検索を無効にする - Active Directory の検索は使用しません。


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、AccessProtectionLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合にお勧めします。


自動 アップデートタスク

自動アップデートタスクの設定

オプションの定義

オプション | 定義
ログ ファイル | 動作ログを有効にします。
形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
入手可能な、DAT ファイルを取得

新バージョンが入手可能な場合には、最新バージョンの DAT ファイルを取得します。
入手可能な、新しい検出エンジンを取得する

新バージョンが入手可能な場合には、最新バージョンのエンジン ファイルまたは DAT ファイル (あるいはその両方) を取得します。
他の入手可能なアップデート (サービス パック、アップグレードなど) を取得する

サービス パックや製品アップグレードなどの最新バージョンを取得します。
アップデートの完了後に実行する実行可能ファイルを入力

自動アップデート タスクの実行が終了した後に起動する実行可能ファイルを指定します。実行する実行可能ファイルのパスを指定するか、または [参照] をクリックして探します。

たとえば、自動アップデートタスクが正しく完了したことを管理者に通知するネットワーク メッセージ ユーティリティを開始できます。

注: 指定するアプリケーションは、現在ログオンしているユーザにより実行可能である必要があります。現在ログオンしているユーザが、アプリケーション ファイルがあるフォルダにアクセスできない場合、または現在ログオンしているユーザがいない場合、アプリケーションは実行されません。
アップデートが成功した場合のみ実行

正常なアップデート後にのみ実行可能ファイルを実行します。正常にアップデートされない場合、指定したアプリケーションは実行されません。
スケジュール

このアップデート タスクのスケジュールを定めます。

注:

詳細については、「タスクのスケジュール」を参照してください。

自動アップデート タスクとミラー タスクを同時に実行するようにスケジュールすることはお勧めできません。どちらのタスクも McAfee Common Framework サービスを使用するため、同時に実行すると矛盾が生じる可能性があります。
今すぐアップデート

自動アップデート タスクを直ちに実行します。


[ブロック] タブ

オプションの定義

共有フォルダに潜在的脅威または望ましくないプログラムが存在するリモート コンピュータからの接続をブロックできます。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
メッセージを送信 | 脅威が検出されたら、ネットワーク ユーザに指定したメッセージを送信する - 脅威が検出されたら、リモート コンピュータのネットワーク ユーザに通知します。
メッセージ テキスト

カスタム メッセージをテキスト ボックスに入力してください。このメッセージを受信するには、リモート コンピュータ上で Windows Messenger サービスが実行されていなければなりません。
接続をブロック
  • 共有フォルダで脅威にさらされたファイルが検出されたときに接続をブロックする - 共有フォルダにある脅威にさらされたファイルの読み取りまたは書き込みを試みるリモート コンピュータ上のすべてのネットワーク ユーザの接続をブロックします。
  • 接続のブロックを解除するまでの時間 - 指定した分数が経過したら、接続のブロックを解除します。時間を分単位で入力します (1 から 9999)。デフォルトは 10 分です。
  • 共有フォルダで不審なプログラムが検出されたときに接続をブロックする - コンピュータに望ましくないプログラムを書き込もうとするリモート コンピュータのユーザへの接続をブロックします。[オンアクセス スキャン統計] ダイアログ ボックスに、ブロックされたコンピュータの一覧が表示されます。


[レポート] タブ

オプションの定義

特定のプロセスのヒープやスタックのオーバーランからローカル システムで実行されるコードの検出を追跡するための記録を有効にします。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、BufferOverflowProtectionLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。


[バッファ オーバーフロー保護] タブ

オプションの定義

バッファ オーバーフロー攻撃手段により、何らかのコードが勝手に実行されることを防止します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
バッファ オーバフローの設定 バッファ オーバーフロー保護を有効にする — バッファ オーバーフロー保護機能を有効にし、保護レベルを選択します。

  • 警告モード - バッファ オーバフローが検出されたら警告を送信します。警告以外のアクションは実行されません。

    このモードは、バッファ オーバーフローの影響が完全に判明していない場合に便利です。機能を短期間 [警告モード] で使用し、その期間中にログ ファイルを参照して、[保護モード] に変更するかどうかを決定します。

  • 保護モード - バッファ オーバフローを検出したらブロックし、その脅威の拡大を防ぎます。

    これにより、該当するアプリケーションも終了します。
クライアント システムの警告 | バッファ オーバーフローの検出時にメッセージを表示する - 検出時に [オンアクセス スキャンのメッセージ] ダイアログ ボックスを表示します。
保護対象から除外するバッファ オーバーフロー 除外情報を指定します。
注:

除外する名前は大文字と小文字を区別します。

  • プロセス - 呼び出しを行っている書き込み可能メモリを所有しているプロセス名を指定します。

    プロセス名またはパスを入力します。

    OUTLOOK.EXE のようにプロセス名のみを入力した場合、プロセスが実行された場所に関係なく、このプロセスは除外されます。C:\Program files\OUTLOOK.EXE のようにパスを含むプロセス名を入力した場合、指定したパスから実行されたプロセスのみが除外されます。ワイルドカードは使用できません。

  • モジュール (オプション) - 該当する場合は、書き込み可能メモリを所有するモジュールの名前を入力します。この情報は必須ではありません。
  • API - 呼び出す API を指定します。
    注:

    API は、モジュールが指定されている場合のみ必須です。


[プロセス] タブ

オプションの定義

すべてのプロセスに共通に適用するスキャン ポリシーを 1 つ設定するのか、それとも既定のプロセス、危険度低プロセス、および危険度高プロセスに適用する複数のスキャン ポリシーを設定するかを決定します。

詳細については、「スキャン ポリシーの数の決定」および「プロセスにどのリスクを割り当てるか決定する」を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
プロセス設定 スキャン ポリシーを設定するかどうかを指定します。
  • すべてのプロセスに適用するスキャン ポリシーを 1 つ設定 - このオプションを選択した場合、設定したポリシーはすべてのプロセスに適用されます。
  • 危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに異なるスキャン ポリシーを設定 - 危険度低プロセスや危険度高プロセスのポリシーを設定するには、このオプションを選択する必要があります。


[表示オプション] タブ

オプションの定義

ユーザがどのシステム トレイ オプションを使用できるかと、優先言語を設定します。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
システム トレイ アイコン
  • すべてのメニュー オプションとともにシステム トレイのアイコンを表示します - ユーザがシステム トレイ メニューのすべてのオプションを表示できるようにします。
  • 最小限のメニュー オプションと共にシステム トレイのアイコンを表示する - システム トレイ メニューの [VirusScan Enterprise のバージョン情報] と [オンアクセス スキャンの統計] 以外のすべてのオプションを非表示します。
  • システム トレイのアイコンを表示しない - すべてのユーザに対して、システム トレイのアイコンを非表示にします。
コンソール オプション
注: このオプションは ePolicy Orchestrator でのみ使用できます。

  • 他のシステムとのリモート コンソール接続を許可 - リモート コンピュータに接続します。

    管理者権限が必要です。また、Remote Registry Service が実行されている必要があります。

  • クライアント コンソールに管理対象タスクを表示 - ePolicy Orchestrator タスクをクライアント コンピュータのコンソール内に表示します。
  • デフォルトの自動アップデート タスク スケジュールを無効にする - デフォルトのアップデート タスクのスケジュールを無効にします。

    このスケジュールは、ポリシーの施行時に無効になります。タスクのスケジュールを無効にするには、タスク マネージャのサービスを実行しておく必要があります。

  • スプラッシュ画面を有効にする - コンソールまたは SHSTAT.EXE の起動時に、VirusScan Enterprise 8.7i のスプラッシュ画面を表示します。
    注:

    このオプションは ePolicy Orchestrator でのみ使用できます。

コンソール言語の設定 コンソール テキストに使用する言語を指定します。
  • 言語は自動的に選択されますが、特定の言語を手動で選択することもできます。
    注:

    VirusScan コンソールで優先言語を変更すると、システムを再起動するように求められます。[はい] をクリックすると、言語の変更が適用されます。

    ePolicy Orchestrator コンソールで優先言語を変更すると、最初のポリシー施行後に言語の変更がユーザのコンソールに適用されます。

    ePolicy Orchestrator 管理対象システムの場合、ユーザがクライアント システムから行った変更はコンソールのインターフェイスに影響しますが、ログ ファイルには ePolicy Orchestrator の設定で指定した言語で動作が記録されます。コンソールの言語変更は、コンソールの再起動後に適用されます。


[アクション] タブ

オプションの定義

脅威または不審なプログラムが検出されたときに実行するアクションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator 経由でのみ使用できます。
脅威が検出された場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト = 添付ファイルの駆除。
  • 添付ファイルの駆除 - スキャナにより、添付ファイルから脅威を削除するアクションが試行されます。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
このオプションについては、2 番目のアクションは指定できません。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
このオプションについては、2 番目のアクションは指定できません。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
  • メールの削除 (Outlook スキャン専用) — 潜在的な脅威を含むメールが削除されます。このオプションを最初のアクションとして選択した場合、2 番目のアクションは指定できません。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト = 添付ファイルのフォルダへの移動。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
  • メールの削除 (Outlook スキャン専用) — 潜在的な脅威を含むメールが削除されます。
不審なプログラムが見つかった場合 このアクションを最初に実行 - 不審なプログラムの検出時にスキャナに実行させる最初のアクションを選択します。デフォルト = 添付ファイルの駆除。
  • 添付ファイルの駆除 - スキャナにより、添付ファイルから脅威を削除するアクションが試行されます。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
このオプションについては、2 番目のアクションは指定できません。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
このオプションについては、2 番目のアクションは指定できません。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト = 添付ファイルのフォルダへの移動。
  • アクションを指定 - 脅威が検出されたときに、ユーザに特定のアクションの実行を求めるプロンプトを表示します。このオプションをクリックした場合は、[[処理設定] ダイアログ ボックスに表示される、許可されたアクション] で、ユーザに許可するアクションを指定します。
このオプションについては、2 番目のアクションは指定できません。
  • スキャンの続行 - 脅威が含まれる添付ファイルが検出された場合でもスキャンが続行されます。
このオプションについては、2 番目のアクションは指定できません。
  • 添付ファイルのフォルダへの移動 - 潜在的脅威を含む添付ファイルが、指定されたフォルダに移動されます。
  • 添付ファイルの削除 - 潜在的な脅威を含む添付ファイルが、検出と同時に削除されます。Microsoft Outlook では、電子メールが削除されます。Lotus Notes では、添付ファイルが削除されます。
移動先フォルダ 隔離フォルダの場所を指定します。隔離フォルダは、ハード ドライブに配置する必要があります。これはローカル ドライブにしてください。フロッピー ドライブや CD ドライブには配置しないでください。隔離フォルダのデフォルトの場所は、Microsoft Outlook と Lotus Notes とでは異なります。
  • Microsoft Outlook では、隔離フォルダは Microsoft Outlook のメールボックスにあります。
  • Lotus Notes では、隔離フォルダはファイル システムにあります。
[処理設定] ダイアログ ボックスでアクションを選択 アクションの指定を求めるダイアログ ボックスでユーザが指定できるアクションを選択します。
注:

デフォルトでは、以下のアクションが実行される前に [アクセスの拒否] アクションが発生します。

  • 添付ファイルの駆除
  • 添付ファイルを削除
  • 添付ファイルを移動
  • メールの削除 (Microsoft Outlook 専用)
ユーザがアクションの実行を求められると、[アラート] タブで指定したメッセージが表示されます。


[アラート] タブ

オプションの定義

配信時電子メール スキャナでのアラートの設定を行えます。

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザの電子メール アラート | ユーザへのアラート メールの送信 - 脅威が埋め込まれた電子メールが検出されたら、もう 1 人のユーザに通知します。
アクションを指定メッセージ | ユーザがアクションの実行を求められたときに表示されるメッセージを指定します。[アクション] タブで [アクションを指定] オプションを選択する必要があります。デフォルトのメッセージをそのまま使用するか、新しいメッセージを入力します。デフォルトのメッセージ = McAfee VirusScan Enterprise 電子メール スキャナ : アラート!


［スキャン アイテム］ タブ

オプションの定義

オンデマンド 電子メール スキャナの検出オプションを設定します。

オプション | 定義
スキャン対象メッセージ
  • 強調表示したすべてのアイテム — 選択した電子メール メッセージとフォルダをスキャンします。
  • [受信] フォルダ内のすべてのメッセージ — 現在 [受信] フォルダおよびそのサブフォルダ内にあるすべてのメッセージをスキャンします。
    • 読み込まれなかったメッセージのみをスキャンする — [受信] フォルダとそのサブフォルダにある未読メッセージをすべてスキャンします。
スキャンする添付ファイル
  • すべての添付ファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。[デフォルトと追加のファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

    添付ファイルにマクロが潜んでいないかもすべてスキャンする - [デフォルトと追加のファイルの種類] を選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    [指定したファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。
ヒューリスティック
  • アプリケーションに感染する未知のウイルスとトロイの木馬を検索 - ヒューリスティック スキャン機能を使用して、マルウェアと類似するコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 - ヒューリスティック スキャン機能を使用して、未知のマクロ ウイルスを検出します。
  • 複数の拡張子を持つ添付ファイルを検索 - 複数の拡張子を持つ添付ファイルを脅威として扱います。

    このオプションをクリックすると、［電子メール スキャンの警告］ ダイアログ ボックスが表示されます。[OK] をクリックして、指定を確認します。
圧縮ファイル
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。

    圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。

  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
不審なプログラムの検出 不審なプログラムを検出 - 配信時電子メール スキャナを有効にして、不審なプログラムを検出します。電子メール スキャナでは、[不審なプログラム ポリシー] で設定された情報を使用して不審なプログラムを検出します。

詳細については、「不審なプログラムの制限」を参照してください。
電子メール メッセージ本文 (Microsoft Outlook 専用) | 電子メール メッセージ本文をスキャン - Microsoft Outlook の電子メール メッセージをスキャンします。


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

配信時電子メール ログ ファイルのデフォルト名は EmailOnDeliveryLog.txt です。

オンデマンド電子メール ログ ファイルのデフォルト名は EmailOnDemandLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ>:\Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
スキャン活動以外にログに記録する処理
  • セッションの設定 - 各スキャン セッションのプロパティをログ ファイルに記録します。
  • セッション サマリ - 各スキャン セッション中にスキャナが実行したアクションのサマリをログ ファイルに記録します。このサマリ情報には、スキャンされたファイルの数、検出された脅威の数とタイプ、駆除、または削除されたファイルの数、およびその他の情報が含まれます。
  • 暗号化ファイルのスキャン失敗 - スキャンに失敗した暗号化ファイルの名前を記録します。
  • ユーザ名 - ログ エントリを書き込むときにコンピュータにログオンしていたユーザ名をログ ファイルに記録します。


［スキャン アイテム］ タブ

オプションの定義

電子メール スキャナでの検出オプションの設定を行えます。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
電子メールのスキャン 配信時電子メールのスキャンを有効にします。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
スキャンする添付ファイル
  • すべての添付ファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。[デフォルトと追加のファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

    添付ファイルにマクロが潜んでいないかもすべてスキャンする - [デフォルトと追加のファイルの種類] を選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    [指定したファイルの種類] を選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。
ヒューリスティック
  • アプリケーションに感染する未知のウイルスとトロイの木馬を検索 - ヒューリスティック スキャン機能を使用して、破壊工作ソフトと共通点のあるコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 - ヒューリスティック スキャン機能を使用して、未知のマクロ ウイルスを検出します。
  • 複数の拡張子を持つ添付ファイルを検索 - 複数の拡張子を持つ添付ファイルを脅威として扱います。

    このオプションをクリックすると、［電子メール スキャンの警告］ ダイアログ ボックスが表示されます。[OK] をクリックして、指定を確認します。
圧縮ファイル
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。

    圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。

  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
不審なプログラムの検出 不審なプログラムを検出 - 配信時電子メール スキャナを有効にして、不審なプログラムを検出します。電子メール スキャナでは、[不審なプログラム ポリシー] で設定された情報を使用して不審なプログラムを検出します。

詳細については、「不審なプログラムの制限」を参照してください。
電子メール メッセージ本文 (Microsoft Outlook 専用) | 電子メール メッセージ本文をスキャン - Microsoft Outlook の電子メール メッセージをスキャンします。
不審なファイルのヒューリスティック ネットワーク チェック
検出したサンプルがマルウェアかどうかを決定するときに使用する感度レベルを設定します。[無効] 以外のすべてのレベルでは、マルウェアであるかどうかを判別するためにサンプルの指紋、つまりハッシュが Avert Labs に送信されます。ユーザにとっての利点は、AVERT Labs がアップデートを発行すると直ちに検出内容を利用でき、次の DAT リリースまで待つ必要がないことです。選択する感度レベルが高いほど、マルウェアの検出数は多くなります。ただし、検出数が増えると、フォルスポジティブの数も増える可能性があります。以下の感度レベルから選択してください。

  • 無効 - 指紋もデータも Avert Labs に送信されず、マルウェアかどうかは決定されません。

  • 非常に低 - フォルスポジティブの検出とリスクは、通常の DAT の場合と同じです。VirusScan Enterprise で検出を使用できるのは、次の DAT の更新を待たず、Avert Labs から公開されるときです。

  • 低 - このレベルは、[非常に低] と [中] の間と定義されています。

  • 中 - このレベルを使用するのは、マルウェアに感染する通常のリスクが、フォルスポジティブのリスクよりも大きい場合です。Avert Labs 独自のヒューリスティック チェックによって、マルウェアの可能性が高いものが検出されます。ただし、一般的ではないファイルについて検出する場合、フォルスポジティブという結果になる危険性もあります。Avert Labs では、検出をこの設定にしたときに、人気があるアプリケーションやオペレーティング システム ファイルについて、フォルスポジティブが生成されないようにチェックしています。

  • 高 - このレベルは、[中] と [非常に高] の間と定義されています。

  • 非常に高 - このレベルを使用するのは、電子メールと、プログラムやオペレーティング システムの実行をサポートしていないボリュームとディレクトリのみにすることをお勧めします。このレベルで検出されるものはマルウェアと推定されますが、フォルスポジティブではないと確定できるほど完全にはテストされていません。


[全般] タブ

オプションの定義

全般的なオンアクセス スキャン オプションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
スキャン 以下の一般的なスキャン アイテムを指定します。
  • ブート セクタ - ブート セクタをスキャンします。
  • フロッピー (シャットダウン時) - コンピュータのシャットダウン時にフロッピー ドライブをスキャンします。

  • 有効なプロセス - McAfee オンアクセス McShield サービスは、既に実行されているすべてのプロセスをスキャンします。
オンアクセス スキャンを有効にする スキャンを有効にするタイミングを指定します。
  • システム起動時にオンアクセス スキャンを有効にする - コンピュータを起動するたびにオンアクセス スキャナを有効にします。
  • ポリシーを施行するときにオンアクセス スキャンを有効にする - ポリシーを施行するたびにオンアクセス スキャナを有効にします。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
最大スキャン タイム アーカイブの最大スキャン タイム - アーカイブの最大スキャン タイムを秒単位で指定します。デフォルト値 = 15 秒。 アーカイブのスキャンに対して指定する秒数は、すべてのファイルに対して指定した最大スキャン タイムより少なくする必要があります。
  • すべてのファイルに対して最大スキャン タイムを強制する - すべてのファイルに対する最大スキャン タイムを定義し、強制的に適用します。
  • 最大スキャン タイム - すべてのファイルに対する最大スキャン タイムを秒単位で指定します。デフォルト値 = 45 秒。
注: スキャンの経過時間が制限時間を上回ると、スキャンは完全に停止してログにメッセージが記録されます。スキャンの完全な停止が不可能な場合は、スキャンは終了して、次回のスキャン時に再開されます。
Cookie
注: このオプションを使用できるのは、AntiSpyware Enterprise Module 8.7 をインストールした場合のみです。

Cookie ファイルをスキャン - Cookie ファイルのスキャンを有効にします。


[プロセス] タブ

オプションの定義 : 手順 1

危険度高プロセスに定義するプロセスを指定します。これは、2 段階のプロセスで行います。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
プロセス設定

[オンアクセス スキャンのデフォルト プロセス ポリシー] を開き、以下のように選択します。

  • 危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定
注:

危険度低プロセスまたは危険度高プロセスのポリシーを設定するには、このオプションを選択する必要があります。

オプションの定義 : 手順 2

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注: このオプションは ePolicy Orchestrator でのみ使用できます。
危険度高プロセス | [オンアクセス スキャンの危険度高プロセス ポリシー] を開き、危険度高プロセスと見なすプロセスを指定します。必要に応じて、プロセスの追加と削除を行います。

詳細については、「スキャン ポリシーの数の決定」および「プロセスにどのリスクを割り当てるか決定する」を参照してください。


[プロセス] タブ

オプションの定義 : 手順 1

危険度低プロセスに定義するプロセスを指定します。これは、2 段階のプロセスで行います。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
プロセス設定

[オンアクセス スキャンのデフォルト プロセス ポリシー] を開き、以下のように選択します。

  • 危険度高プロセス、危険度低プロセス、およびデフォルト プロセス向けに、それぞれ異なるスキャン ポリシーを設定
注:

危険度低プロセスまたは危険度高プロセスのポリシーを設定するには、このオプションを選択する必要があります。

オプションの定義 : 手順 2

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注: このオプションは ePolicy Orchestrator でのみ使用できます。
危険度低プロセス | [オンアクセス スキャンの危険度低プロセス ポリシー] を開き、危険度低プロセスと見なすプロセスを指定します。必要に応じて、プロセスの追加と削除を行います。

詳細については、「スキャン ポリシーの数の決定」および「プロセスにどのリスクを割り当てるか決定する」を参照してください。


[メッセージ] タブ

オプションの定義

ローカル ユーザおよび管理者権限を持たないユーザに対するメッセージ オプションを設定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザ メッセージ ローカル ユーザが受信するメッセージを指定します。
  • 脅威が検出されたときにメッセージのダイアログ ボックスを表示し、メッセージに指定されたテキストを表示します - 検出が発生すると、［オンアクセス スキャンのメッセージ］ ダイアログ ボックスがローカル ユーザに表示されます。

  • Cookie の検出が発生したときにアラートを生成します - Cookie が検出されると、アラートが送信されます。たとえば、ePolicy Orchestrator アラートの生成、[オンアクセス スキャンのメッセージ] ダイアログ ボックスへのメッセージの送信、[レポート] タブで動作ログを有効にした場合は検出結果の動作ログへの記録、検出結果のスキャン統計への組み込みなどです。このオプションをオフにすると、ePolicy Orchestrator からのアラートは生成されませんが、[レポート] タブで動作ログを有効にした場合は、動作ログに記録されます。また、スキャン統計に組み込まれます。

    注:

    このオプションを使用できるのは、AntiSpyware Enterprise Module 8.7 をインストールした場合のみです。
メッセージ テキスト

デフォルトのメッセージをそのまま使用するか、カスタム メッセージを入力します。デフォルト値 = VirusScan のアラートです。
ユーザが使用できるアクション
  • リストからメッセージを削除 - 管理者権限のないユーザに対し、リストからメッセージを削除する操作を許可します。
  • ファイルを駆除 - 管理者権限のないユーザに対し、リストのメッセージに示されるファイルの駆除操作を許可します。
  • ファイルを削除 - 管理者権限のないユーザに対し、リストのメッセージに示されるファイルの削除操作を許可します。


ミラー タスク

ミラー タスクの設定

VirusScan コンソール — オプションの定義

オプション | 定義
ログ ファイル | 動作ログを有効にします。
形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
入手可能な、新しいDAT ファイルを取得

このオプションは、ミラー タスクには適用されません。
入手可能な、新しい検出エンジンを取得する

このオプションは、ミラー タスクには適用されません。
他の入手可能なアップデート (サービス パック、アップグレードなど) を取得する

このオプションは、ミラー タスクには適用されません。
ミラーリングの完了後に実行する実行可能ファイルを入力

ミラー タスクの実行が終了した後に起動する実行可能ファイルを指定します。実行する実行可能ファイルのパスを指定するか、または [参照] をクリックして探します。

たとえば、ミラー タスクが正しく完了したことを管理者に通知するネットワーク メッセージ ユーティリティを開始できます。

注: 指定するアプリケーションは、現在ログオンしているユーザにより実行可能である必要があります。現在ログオンしているユーザが、アプリケーション ファイルがあるフォルダにアクセスできない場合、または現在ログオンしているユーザがいない場合、アプリケーションは実行されません。
ミラーが成功した場合のみ実行

正常なミラーリング後にのみ実行可能ファイルを実行します。正常にミラーリングされない場合、指定したアプリケーションは実行されません。
ミラーリングのロケーション

ミラー サイトに使用しているローカル システム上のミラーリング先のパスを指定します。

注: システム変数がサポートされています。
スケジュール

このアップデート タスクのスケジュールを定めます。

注:

詳細については、「タスクのスケジュール」を参照してください。

自動アップデート タスクとミラー タスクを同時に実行するようなスケジュールは立てないでください。どちらのタスクも McAfee Common Framework サービスを使用するため、同時に実行すると矛盾が生じる可能性があります。
今すぐミラー

ミラー タスクを直ちに実行します。


[Notes スキャナの設定] タブ

オプションの定義

配信時電子メール スキャナでの Lotus Notes の設定を行えます。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
サーバ スキャンの設定
  • すべてのサーバ データベースのスキャン - 潜在的な脅威がないかすべてのサーバ データベースをスキャンします。
  • サーバのメールボックスのスキャン - 潜在的な脅威がないかすべてのサーバのメールボックスををスキャンします。
  • メールボックスのルート フォルダ - ルート フォルダの場所を指定します。メールボックスのルート フォルダ用にデフォルトの場所を使用するか、新しい場所を指定します。このオプションは、配信時電子メール スキャンでのみ使用できます。デフォルト値 = !!mail\。
詳細オプション | 除外する Notes アプリケーション - スキャンから除外する Lotus Notes アプリケーションを指定します。デフォルト値 = MNOTES。


[アクション] タブ

オプションの定義

脅威または不審なプログラムが検出されたときに実行するアクションを設定できます。デフォルト プロセス、危険度低プロセス、危険度高プロセスのそれぞれに異なるスキャン ポリシーを設定する場合は、このタブのオプションをプロセスの種類ごとに設定する必要があります。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
脅威が検出された場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルの自動的駆除。
  • ファイルの自動的駆除 - スキャナにより、検出されたファイルから脅威を削除するアクションが試行されます。
  • ファイル アクセスの拒否 - スキャナによって検出された潜在的な脅威を含むすべてのファイルについて、全ユーザからのアクセスを拒否します。
  • ファイルの自動削除 - 潜在的な脅威を含むファイルが、スキャナによって検出と同時に削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルの自動削除。
  • ファイル アクセスの拒否 - スキャナによって検出された潜在的な脅威を含むすべてのファイルについて、全ユーザからのアクセスを拒否します。
  • ファイルの自動削除 - 潜在的な脅威を含むファイルが、スキャナによって検出と同時に削除されます。
不審なプログラムが見つかった場合 このアクションを最初に実行 - 不審なプログラムの検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルの自動的駆除。
  • ファイル アクセスの許可 - 検出されたファイルまたはプログラムへのアクセスをユーザに許可します。
    注:

    このアクションを使用すると、実行するアクションを判断する前に検出物を監視できます。動作ログを調べて、どのプログラムが検出されているのかを確認します。このオプションについては、2 番目のアクションは指定できません。

  • ファイルの自動的駆除 - 検出されたファイルまたはプログラムから脅威を自動的に削除します。
  • ファイル アクセスの拒否 - ユーザによる検出されたファイルまたはプログラムへのアクセスを拒否します。
  • ファイルの自動削除 - 検出されたファイルまたはプログラムを自動的に削除します。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルの自動削除。
  • ファイル アクセスの許可 - 検出されたファイルまたはプログラムへのアクセスをユーザに許可します。
  • ファイル アクセスの拒否 - ユーザによる検出されたファイルまたはプログラムへのアクセスを拒否します。
  • ファイルの自動削除 - 検出されたファイルまたはプログラムを自動的に削除します。


[除外] タブ

オプションの定義

スキャンから除外するアイテムを指定します。デフォルト プロセス、危険度低プロセス、危険度高プロセスのそれぞれに異なるスキャン ポリシーを設定する場合は、このタブのオプションをプロセスの種類ごとに設定する必要があります。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
スキャン対象外 ドロップダウン リストから除外の種類を選択し、除外についての詳細を以下のように指定します。
  • パターンを指定して除外 - 除外するパターンをテキスト ボックスに入力します。必要に応じて、[サブフォルダも対象] を選択します。
  • ファイルの種類を指定して除外 - 除外するファイルの種類をテキスト ボックスに入力します。
  • ファイルの保存期間を指定して除外 - アクセス タイプを選択し、ファイルが作成されてからの経過日数を指定します。
  • Windows ファイル保護機能で保護されているファイル

詳細については、「スキャン アイテムの追加と除外」を参照してください。
クライアントの除外対象の処理方法 クライアントの除外対象を上書き - このポリシーで指定されたアイテムのみを除外します。このオプションが選択されていない場合、クライアント コンピュータではローカルで指定した除外対象およびこのポリシーで指定した除外対象を使用します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、OnAccessScanLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ> : \Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\。

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
スキャン活動以外にログに記録する処理
  • セッションの設定 - 各スキャン セッションのプロパティをログ ファイルに記録します。
  • セッション サマリ - 各スキャン セッション中にスキャナが実行したアクションのサマリをログ ファイルに記録します。このサマリ情報には、スキャンされたファイルの数、検出された脅威の数とタイプ、駆除、または削除されたファイルの数、およびその他の情報が含まれます。
  • 暗号化ファイルのスキャン失敗 - スキャンに失敗した暗号化ファイルの名前を記録します。


［スキャン アイテム］ タブ

オプションの定義

検出オプションを設定できます。デフォルト プロセス、危険度低プロセス、危険度高プロセスのそれぞれに異なるスキャン ポリシーを設定する場合は、このタブのオプションをプロセスの種類ごとに設定する必要があります。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ファイルのスキャン
  • ディスクへの書き込み時 - すべてのファイルについて、コンピュータまたは他の記憶領域で書き込みや修正がされた場合に、スキャンを実行します。

    複数のコンピュータ間でファイルをコピーまたは移動する場合は、潜在的な脅威が含まれるファイルをコンピュータからコピーしたりコンピュータに書き込むことができないように、すべてのコンピュータを同じ設定にすることが重要です。

  • ディスクからの読み取り時 - コンピュータ上またはその他のデータ記憶装置上のファイルからの読み取り時に、その対象ファイルがすべてスキャンされます。
  • ネットワーク ドライブ上 - マップされているネットワーク ドライブ上のリソースをスキャンします。

    ネットワーク上のリソースをスキャンすると、パフォーマンスが低下する場合があります。

  • バックアップ用に開いたファイル - バックアップ処理用に開いたファイルをスキャンします。
スキャンするファイルの種類
  • すべてのファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。

    ファイルにマクロが潜んでいないかもすべてスキャンする - このオプションを選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    このオプションを選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。
ヒューリスティック
  • アプリケーションに感染する未知のウイルスとトロイの木馬を検索 - ヒューリスティック スキャン機能を使用して、破壊工作ソフトと共通点のあるコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 - ヒューリスティック スキャン機能を使用して、未知のマクロ ウイルスを検出します。
圧縮ファイル
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。
  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
注: 圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。
不審なプログラムの検出
  • 不審なプログラムを検出 - オンアクセス スキャナを有効にして、不審なプログラムを検出します。

    スキャナでは、[不審なプログラム ポリシー] で設定された情報を使用して不審なプログラムを検出します。

    詳細については、「不審なプログラムの制限」を参照してください。


[アクション] タブ

オプションの定義

脅威または不審なプログラムが検出されたときに実行するアクションを設定できます。

オプション 定義
脅威が検出された場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルを駆除。
  • ウイルスを駆除 - スキャナにより、検出されたファイルから脅威を削除するアクションが試行されます。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルの自動削除 - 潜在的な脅威を含むファイルが、スキャナによって検出と同時に削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルを削除。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルを削除 - 潜在的な脅威を含むファイルが、検出と同時に削除されます。
不審なプログラムが見つかった場合 このアクションを最初に実行 - 脅威検出時にスキャナに実行させる最初のアクションを選択します。デフォルト値 = ファイルを駆除。
  • ファイルを駆除 - スキャナにより、検出されたファイルから脅威を削除するアクションが試行されます。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルを削除 - 潜在的な脅威を含むファイルが、検出と同時に削除されます。
最初のアクションが失敗したときに、このアクションを実行 - 最初のアクションが失敗したときに実行される次のアクションを選択します。デフォルト値 = ファイルを削除。
  • スキャンを続行 - 脅威にさらされたファイルが検出された場合でもスキャンが続行されます。
  • ファイルを削除 - 潜在的な脅威を含むファイルが、検出と同時に削除されます。


[除外] タブ

オプションの定義

スキャンから除外するアイテムを指定します。

オプション 定義
スキャン対象外 ドロップダウン リストから除外の種類を選択し、除外についての詳細を以下のように指定します。
  • パターンを指定して除外 - 除外するパターンをテキスト ボックスに入力します。必要に応じて、[サブフォルダも対象] を選択します。
  • ファイルの種類を指定して除外 - 除外するファイルの種類をテキスト ボックスに入力します。
  • ファイルの保存期間を指定して除外 - アクセス タイプを選択し、ファイルが作成されてからの経過日数を指定します。
  • Windows ファイル保護機能で保護されているファイル

詳細については、「スキャン アイテムの追加と除外」を参照してください。
クライアントの除外対象の処理方法 クライアントの除外対象を上書き - このポリシーで指定されたアイテムのみを除外します。このオプションが選択されていない場合、クライアント コンピュータではローカルで指定した除外対象およびこのポリシーで指定した除外対象を使用します。
注:

このオプションは、ePolicy Orchestrator によってのみ設定します。


[パフォーマンス] タブ

オプションの定義

パフォーマンスを改善するには、スキャンの遅延とシステム使用率のオプションを指定します。

オプション | 定義
スキャンの遅延オプション スキャンの遅延オプションを選択します。
  • 電源に電池を使用しているときにスキャンを遅らせる - システムが使用中であり、電源に電池を使用しているときに、スキャンを遅らせます。
  • プレゼンテーション中にスキャンを遅らせる - システムがプレゼンテーション モードのときに、スキャンを遅らせます。
  • ユーザにスケジュール スキャンの遅延を許可 - ユーザがスケジュール スキャンを遅らせることができるようにします。

  • 遅延時間 - スキャンを遅らせる時間の長さを指定します。1～24 時間を選択します。また、スキャンを永続的に遅らせるには 0 を選択します。

詳細については、「スキャンの遅延の機能」を参照してください。
システムの使用率 | スライダを使用して、スキャンに適用するシステム使用率のスケジュールを設定します。個々のスキャン タスクは、他のタスクのシステム使用率の制限レベルに関係なく独立して実行されます。ePolicy Orchestrator のこのタスクのデフォルト値 = 30%.VirusScan Enterprise 8.7i のこのタスクのデフォルト値 = 100 %.
不審なファイルのヒューリスティック ネットワーク チェック
検出したサンプルがマルウェアかどうかを決定するときに使用する感度レベルを設定します。[無効] 以外のすべてのレベルでは、マルウェアであるかどうかを判別するためにサンプルの指紋、つまりハッシュが Avert Labs に送信されます。ユーザにとっての利点は、AVERT Labs がアップデートを発行すると直ちに検出内容を利用でき、次の DAT リリースまで待つ必要がないことです。選択する感度レベルが高いほど、マルウェアの検出数は多くなります。ただし、検出数が増えると、フォルスポジティブの数も増える可能性があります。以下の感度レベルから選択してください。

  • 無効 - 指紋もデータも Avert Labs に送信されず、マルウェアかどうかは決定されません。

  • 非常に低 - フォルスポジティブの検出とリスクは、通常の DAT の場合と同じです。VirusScan Enterprise で検出を使用できるのは、次の DAT の更新を待たず、Avert Labs から公開されるときです。

  • 低 - このレベルは、[非常に低] と [中] の間と定義されています。

  • 中 - このレベルを使用するのは、マルウェアに感染する通常のリスクが、フォルスポジティブのリスクよりも大きい場合です。Avert Labs 独自のヒューリスティック チェックによって、マルウェアの可能性が高いものが検出されます。ただし、一般的ではないファイルについて検出する場合、フォルスポジティブという結果になる危険性もあります。Avert Labs では、検出をこの設定にしたときに、人気があるアプリケーションやオペレーティング システム ファイルについて、フォルスポジティブが生成されないようにチェックしています。

  • 高 - このレベルは、[中] と [非常に高] の間と定義されています。

  • 非常に高 - このレベルを使用するのは、電子メールと、プログラムやオペレーティング システムの実行をサポートしていないボリュームとディレクトリのみにすることをお勧めします。このレベルで検出されるものはマルウェアと推定されますが、フォルスポジティブではないと確定できるほど完全にはテストされていません。


[レポート] タブ

オプションの定義

ログを有効にして、ネットワーク状況の追跡、検出に使用した設定の記録、およびスキャナが見つけた潜在的脅威への対処に使用します。

オプション | 定義
ログ ファイルに記録 | 動作ログを有効にします。
ログ ファイルの場所 ログ ファイル用にデフォルトの場所を使用するか、新しい場所を指定します。

デフォルトのログ名は、OnDemandScanLog.txt です。

デフォルトの場所は次のとおりです。<ドライブ> : \Documents and Settings\All Users\Application Data\McAfee\DesktopProtection\。

ファイルのデフォルトの場所は、使用しているオペレーティング システムによって異なります。
ログ ファイルのサイズ | ログ ファイルのサイズを制限します。デフォルトのサイズ (1 MB) をそのまま使用するか、または 1 ～ 999 MB の範囲でサイズを設定します。ログ ファイルのデータが、ユーザが設定したファイル サイズを超えると、エントリのうち古い側から 20% が削除され、新しいデータがファイルに追加されます。
ログ ファイルの形式 ログ ファイルの形式を選択します。デフォルト値 = Unicode (UTF8)。
  • Unicode (UTF8) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • Unicode (UTF16) - 東アジア言語のテキスト (1 文字が 1 バイトまたは 2 バイト) を保存する、または多国籍の組織内で情報を共有する場合に推奨します。
  • ANSI - 西ヨーロッパ言語のテキスト (1 文字が 1 バイト) を保存する場合、ANSI 形式の使用をお勧めします。
スキャン活動以外にログに記録する処理
  • セッションの設定 - 各スキャン セッションのプロパティをログ ファイルに記録します。
  • セッション サマリ - 各スキャン セッション中にスキャナが実行したアクションのサマリをログ ファイルに記録します。このサマリ情報には、スキャンされたファイルの数、検出された脅威の数とタイプ、駆除、または削除されたファイルの数、およびその他の情報が含まれます。
  • 暗号化ファイルのスキャン失敗 - スキャンに失敗した暗号化ファイルの名前を記録します。
Cookie の検出が発生したときにアラートを生成します
注:

このオプションを使用できるのは、AntiSpyware Enterprise Module 8.7 をインストールした場合のみです。

Cookie の検出が発生したときにアラートを生成します - Cookie が検出されると、アラートが送信されます。たとえば、ePolicy Orchestrator アラートの生成、検出の通知、[レポート] タブで動作ログを有効にした場合は検出結果の動作ログへの記録、検出結果のスキャン統計への組み込みなどです。このオプションをオフにすると、ePolicy Orchestrator からのアラートは生成されませんが、[レポート] タブで動作ログを有効にした場合は、動作ログに記録されます。また、スキャン統計に組み込まれます。


［スキャン アイテム］ タブ

オプションの定義

検出オプションを設定できます。

オプション 定義
スキャンするファイルの種類
  • すべてのファイル - 拡張子に関係なく、すべてのファイルをスキャンします。
  • デフォルトと追加のファイルの種類 - デフォルトのリスト内の拡張子、およびその他の指定した拡張子を持つファイルをスキャンします。デフォルトのリストは、現在の DAT ファイルによって定義されます。

    このオプションを選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。

    ファイルにマクロが潜んでいないかもすべてスキャンする - [デフォルトと追加のファイルの種類] を選択すると、すべてのファイルの既知のマクロ ウィルスを検索することもできます。

  • 指定したファイルの種類 - スキャン対象にするユーザ指定拡張子のリストを作成します。以前に追加したどの拡張子でも削除できます。

    このオプションを選択し、ファイル拡張子をスペースで区切ってテキスト ボックスに入力します。
オプション
  • 不審なプログラムを検出 - オンアクセス スキャナを有効にして、不審なプログラムを検出します。

    スキャナでは、[不審なプログラム ポリシー] で設定された情報を使用して不審なプログラムを検出します。

    詳細については、「不審なプログラムの制限」を参照してください。

  • MIME 形式のファイルをデコード - MIME (Multipurpose Internet Mail Extensions) 形式でエンコードされたファイルの検出、デコード、およびスキャンを行います。
  • アーカイブ (.ZIP など) の内部をスキャン - アーカイブ (圧縮) ファイルとその中身を調べます。
圧縮ファイルをスキャンすることで脅威からの防護は強化できますが、個々のスキャンの実行時間が長くなる場合があります。

  • ストレージに移動したファイルをスキャン - リモート ストレージに保存されているキャッシュされたファイルをスキャンします。

    詳細については、「リモート ストレージのスキャンの機能のしくみ」を参照してください。
ヒューリスティック
  • 未知のプログラム脅威を検索 - ヒューリスティック スキャン機能を使用して、破壊工作ソフトと共通点のあるコードを含む実行可能ファイルを検出します。
  • 未知のマクロ ウイルスを検索 - ヒューリスティック スキャン機能を使用して、未知のマクロ ウイルスを検出します。


[タスク] タブ

オプションの定義

このオンデマンド タスクが実行されるプラットフォームを指定できます。

オプション 定義
このタスクが実行されるプラットフォーム
  • このタスクをサーバで実行 - このオンデマンド スキャン タスクをサーバで実行します。
  • このタスクをワークステーションで実行 - このオンデマンド スキャン タスクをワークステーションで実行します。
タスクの実行時に使用するユーザ アカウント
  • ユーザ名 - ユーザのアカウント名を指定します。アカウント情報が入力されていない場合、タスクはシステム アカウントで実行されます。
  • パスワード - パスワードを入力します。
  • ドメイン - ドメインを入力します。
注:

このタスクをスケジュールするには、管理者権限が必要です。管理者権限があると、スケジュール タスクのレジストリ キーへの書き込みアクセスが可能です。クライアント タスクのスケジュールについては、ePolicy Orchestrator のマニュアルを参照してください。


[パスワード オプション] タブ

オプションの定義

システム全体、またはアイテムを選択して、パスワード セキュリティを設定できます。詳細については、「パスワードを設定することによるユーザへの影響」を参照してください。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザ インターフェイス パスワード 以下のユーザ インターフェース セキュリティを指定します。
  • パスワードなし - パスワードを入力しなくても構成設定にアクセスできるようにします。
  • リスト内のすべてのアイテムをパスワードで保護 - リストの全アイテムに 1 つのパスワードを指定します。
  • 選択されたアイテムをパスワードで保護 - リストで選択したアイテムに 1 つのパスワードを指定します。
  • 共通の条件一致設定のパスワード保護 - NIAP (National Information Assurance Partnership) のコモン クライテリアで検証済みのセキュリティ製品以外使用できない政府系機関の要件を満たせるように、インターフェイスをセキュリティ保護します。

    これにより、管理資格情報を持たないユーザからすべての設定をセキュリティ保護します。ただし、ワークステーションのユーザは、自分のワークステーションで即時オンデマンド スキャンを実行できます。ファイルを即時オンデマンド スキャンに組み入れたり、除外できます。.ZIP ファイルなどのアーカイブを即時オンデマンド スキャンに組み入れたり、除外できます。オンデマンド スキャンおよびオンアクセス スキャンの動作ログを表示できます。

パスワード - パスワードを入力します。

パスワードの確認 - パスワードを再度入力して確認します。
ユーザ インターフェイス アイテムのパスワード保護 パスワードで保護するアイテムを選択します。
  • すべて選択 - セクション内のアイテムをすべて選択します。
  • すべて選択解除 - セクション内のアイテムの選択をすべて解除します。

管理者は、[ コンソール] によりインターフェイスをロックまたはロック解除できます。


[ポリシー] タブ

オプションの定義

隔離の場所および隔離アイテムの保管期間を設定します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
検疫ディレクトリ | 検疫ディレクトリ用にデフォルトの場所を使用するか、新しい場所を指定します。デフォルトの場所 = <システムドライブ>\Quarantine。
隔離データの保有期間
  • 隔離データの自動削除 - 隔離アイテムを指定日数後に削除します。
  • バックアップ データを隔離フォルダに保管しておく日数 - 隔離アイテムが自動的に削除されるまで保管しておく日数を指定します。1 ～ 999 日から選択します。


[プロキシ設定] タブ

プロキシ サーバは、インターネット ユーザのコンピュータをインターネットから隠し、頻繁にアクセスするサイトをキャッシュしてアクセス速度を向上するためのインターネット セキュリティの一部として使用されます。

ネットワークでプロキシ サーバを使用している場合、使用するプロキシ設定、プロキシ サーバのアドレス、および認証を使用するかどうかを指定できます。プロキシ情報は、自動アップデートのリポジトリ リスト (sitelist.xml) に保存されています。ここで構成するプロキシ設定は、リポジトリ リストにあるすべてのリポジトリに適用されます。

注:

この機能は、ePolicy Orchestrator コンソールでは使用できません。この機能には、VirusScan コンソールからアクセスします。

オプションの定義

オプション 定義
プロキシを使用しない

プロキシ サーバを指定しません。

Internet Explorer のプロキシ設定を使用

現在インストールしているバージョンの Internet Explorer にプロキシ設定を使用します。

デフォルト値 = Internet Explorer のプロキシ設定を使用。
プロキシ設定を手動で構成する

具体的な必要に合うようにプロキシ設定を構成します。
例外

これを使用できるのは、[プロキシ設定を手動で構成する] を選択していた場合のみです。

プロキシの例外を指定します。[例外］ をクリックして、［プロキシの例外］ ダイアログ ボックスを開きます。
  • 例外の指定 - プロキシの例外を設定するには、このオプションを選択します。
  • 複数のエントリを区切るにはセミコロン (;) を使用します。例 : internal1;internal2
HTTP

HTTP プロキシ サーバのアドレスを入力します。
FTP

FTP プロキシ サーバのアドレスを入力します。
ポート

HTTP プロキシ サーバまたは FTP プロキシ サーバのポート番号を入力します。
HTTP で認証を使用

HTTP プロキシのアクセスに指定された資格情報を使用します。
HTTP ユーザ名

HTTP ユーザ名を入力します。
HTTP パスワード

HTTP パスワードを入力します。


［スキャン アイテム］ タブ

オプションの定義

検出対象とする不審なプログラムのカテゴリを選択し、検出しないプログラムについては除外対象を作成できます。

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注: このオプションは ePolicy Orchestrator でのみ使用できます。
検出する不審なプログラムのカテゴリを選択します。 | 検出する不審なプログラムのカテゴリを指定します。
不審なプログラムから除外 | 除外対象を検出名で指定します。必要に応じて、アイテムの追加と削除を行います。


[検疫ポリシー] タブ

オプションの定義

隔離の場所および隔離アイテムの保管期間を設定します。

オプション | 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
検疫ディレクトリ | 検疫ディレクトリ用にデフォルトの場所を使用するか、新しい場所を指定します。デフォルトの場所 = <システムドライブ>\Quarantine。
隔離データの保有期間
  • 隔離データの自動削除 - 隔離アイテムを指定日数後に削除します。
  • バックアップ データを隔離フォルダに保管しておく日数 - 隔離アイテムが自動的に削除されるまで保管しておく日数を指定します。1 ～ 999 日から選択します。


リポジトリの追加と編集

新しいリポジトリを追加するか、既存のレポジトリを編集します。

オプションの定義

オプション 定義
リポジトリの説明

リポジトリの名前を指定します。
ファイルの取得先
ファイルの取得先を選択します。デフォルト = HTTP リポジトリ。
  • HTTP リポジトリ - 指定した HTTP リポジトリの場所からファイルを取得します。
    注: HTTP サイトでは、FTP と同様に、ネットワークのセキュリティとは独立したアップデートが得られますが、FTP よりも高レベルな同時接続がサポートされます。
  • FTP リポジトリ - 指定した FTP リポジトリの場所からファイルを取得します。
    注: FTP サイトには、ネットワーク セキュリティのアクセス許可を順守せずにアップデートできる柔軟性があります。FTP は、HTTP よりも怪しいコード攻撃にさらされることが少ないため、脅威に対する抵抗力が増す場合があります。
  • UNC パス - 指定した UNC パスの場所からファイルを取得します。
    注: UNC サイトは、最も迅速にまた簡単にセットアップできます。ドメイン間で UNC アップデートを行うには、各ドメインでセキュリティのアクセス許可が必要で、アップデートの設定が複雑になります。
  • ローカル パス - 指定したローカル パスからファイルを取得します。
URL
これを使用できるのは、[HTTP リポジトリ] または [FTP リポジトリ] を選択していた場合のみです。
  • HTTP — アップデート ファイルがある HTTP サーバおよびフォルダの場所を入力します。
  • FTP — アップデート ファイルがある FTP サーバおよびフォルダの場所を入力します。
パス
これを使用できるのは、[UNC パス] または [ローカル パス] を選択していた場合のみです。
  • UNC パス — UNC 表記 (\\servername\path\) を使用して、アップデート ファイルがあるリポジトリのパスを入力します。
  • ローカル パス — アップデート ファイルを配置したローカル フォルダのパスを入力するか、または [参照] をクリックして、フォルダに移動します。パスは、ローカル ドライブまたはネットワーク ドライブのフォルダへのパスが使用できます。
ポート

これを使用できるのは、[HTTP リポジトリ] または [FTP リポジトリ] を選択していた場合のみです。指定した HTTP サーバまたは FTP サーバのポート番号を入力します。

ユーザ認証

匿名ログインを使用

ログオン アカウントの使用
リポジトリへのアクセスに指定された資格情報を使用します。
注:

このオプションの名称は、[ファイルの取得先] で選択したオプションに応じて異なります。

指定した資格情報は、自動アップデートがリポジトリへのアクセスに使用して、必要なアップデート ファイルをダウンロードします。リポジトリのアカウント資格情報を設定する場合、アップデート ファイルを含むフォルダに対して読み取り許可があることを確認します。
  • FTP および UNC リポジトリでは、ダウンロードの資格情報が必要ですが、HTTP リポジトリでは任意です。
  • FTP アップデートでは、匿名でのリポジトリへの接続をサポートします。
  • UNC アップデートでは、ログオン アカウントを使用し、ログオンしているユーザの権限を利用してリポジトリにアクセスすることもできます。
ユーザ名

ユーザ名を入力します。
パスワード

パスワードを入力します。
確認

パスワードを再度入力して確認します。


[リポジトリ] タブ

アップデートの取得元となるリポジトリを設定します。
注:

この機能は、ePolicy Orchestrator コンソールでは使用できません。この機能には、VirusScan コンソールからアクセスします。

オプションの定義

オプション 定義
リポジトリの説明

リポジトリの名前を指定します。

HTTP と FTP のリポジトリに関しては、リストは事前に設定されています。
  • http://update.nai.com/Products/CommonUpdater
  • ftp://ftp.nai.com/CommonUpdater

デフォルトのダウンロード サイトは、HTTP リポジトリです。
状態

有効 - 自動アップデート プロセスで使用可能な定義済みリポジトリです。

無効 - 自動アップデート プロセスで使用しない定義済みリポジトリです。これは、常時ではなく時々使用するリポジトリである場合があります。

注: リポジトリ サイトは必要に応じていくつでも作成し、有効/無効を切り換えます。
追加

新しいリポジトリをリストに追加します。
編集

選択したリポジトリを編集します。
削除

選択したリポジトリを削除します。
上へ

選択したリポジトリをリスト内で上に移動させます。
下へ

選択したリポジトリをリスト内で下に移動させます。


[マネージャ] タブ

リストのアイテムを選択し、右クリックすると、詳細オプションにアクセスできます。再スキャン、フォルスポジティブがないかどうかの確認、復元、削除、プロパティの表示を行うことができます。


[タスク] タブ

オプションの定義

復元する場所へのアクセス権があるユーザのアカウント情報を指定します。アカウントがこのタブに入力されていない場合、復元タスクはシステム アカウントで実行されます。

オプション | 定義
ユーザ | 復元する場所へのアクセス権があるユーザの名前を入力します。
パスワード | 指定したユーザのパスワードを入力します。
ドメイン | 指定したユーザのドメインを入力します。


［スキャンする場所］ タブ

オプションの定義

スキャンするアイテムの種類と場所を設定できます。

オプション 定義
スキャンする場所 スキャン対象の場所を指定します。デフォルト値 = [メモリでのルートキットのスキャン]、[実行中のプロセス]、および [すべてのローカル ドライブ]。[追加]、[編集]、および [削除] をクリックして、[アイテム名] を変更します。
  • メモリでのルートキットのスキャン -システム メモリに、インストールされたルートキット、隠れたプロセス、および不正なコードが自己の隠蔽を謀るような他の動作がないかどうかをスキャンします。このスキャンは、他のすべてのスキャンに先立って実行されます。
  • 実行中のプロセス -実行中のすべてのプロセスのメモリをスキャンします。[駆除] 以外のアクションは、[スキャンを続行] として処理されます。
  • 登録済みファイル - 登録されているすべてのファイルをスキャンします。まず、スキャナによってレジストリでファイル名が検索された後、それらのファイルがスキャンされます。スキャナによって、潜在的に望ましくないファイルに対する参照はレジストリから削除されます。
  • マイ コンピュータ -コンピュータに物理的に取り付けられているか、またはコンピュータにドライブ文字として論理的に割り当てられたすべてのドライブをスキャンします。
  • すべてのローカル ドライブ -コンピュータ上のすべてのドライブおよびそのサブフォルダをスキャンします。
  • すべてのハード ディスク -コンピュータに物理的に接続しているすべてのドライブをスキャンします。
  • すべてのリムーバブル ドライブ -コンピュータに接続されているすべてのリムーバブル ドライブまたはその他の記憶装置をスキャンします。
  • マップされているすべてのネットワーク ドライブ - コンピュータ上のネットワーク ドライブに、論理的にマップされたネットワーク ドライブをスキャンします。
  • ホーム フォルダ - スキャンを開始するユーザのホーム フォルダをスキャンします。
  • ユーザ プロファイル フォルダ - ユーザのマイ ドキュメント フォルダを含めスキャンを開始したユーザのプロファイルをスキャンします。
  • Windows フォルダ -Windows フォルダの中身をスキャンします。
  • Program Files フォルダ -Program Files フォルダの中身をスキャンします。
  • Temp フォルダ -Temp フォルダの中身をスキャンします。
  • ごみ箱 -ごみ箱に含まれるコンテンツをスキャンします。
  • ドライブまたはフォルダ -指定したドライブまたはフォルダをスキャンします。
  • ファイル -指定したファイルをスキャンします。
  • レジストリ - レジストリ エントリをスキャンします。この場所を使用できるのは、AntiSpyware Enterprise Module 8.7 をインストールした場合のみです。
  • Cookie - Cookies フォルダ内の Cookie をスキャンします。この場所を使用できるのは、AntiSpyware Enterprise Module 8.7 をインストールした場合のみです。
注: スキャン アイテムのデフォルトのリストをそのまま使用すると、スキャンする場所が多すぎて非常に時間がかかる場合があります。定期的なスキャン タスクについては、アイテムの範囲を絞れるかどうか検討することをお勧めします。
スキャン オプション 選択したアイテムのスキャンの種類。
  • サブフォルダも対象 - 指定したボリューム内のすべてのサブフォルダがスキャンされます。このチェック ボックスをオフにすると、ボリュームのルート レベルのみがスキャンされます。
  • ブート セクタをスキャン - ディスクのブート セクタをスキャンします。
ただし、ディスクに固有のブート セクタが存在し、スキャン対象にできないような場合には、ブート セクタのスキャンは無効にすることをお勧めします。


スケジュールの詳細設定

スケジュール パラメータを設定します。

オプションの定義

オプション | 定義
開始日 | このタスクを開始する日を指定します。
終了日 | このタスクを終了する日を指定します。
繰り返しタスク | 指定した頻度でタスクを繰り返します。 このオプションを指定する場合、このタスクを繰り返す頻度も指定します。
間隔 | このタスクを繰り返す頻度を指定します。 その頻度が時間単位か分単位かも選択します。
時間 (現地) | 指定された現地時刻にこのタスクを繰り返します。 このオプションを選択する場合、特定の時間も選択します。
期間 | 指定された時間と分の期間このタスクを繰り返します。 このオプションを選択する場合、時間と分も選択します。
時 | 時間単位の時間。0 ～ 99 から選択します。
分 | 分単位の時間。0 ～ 59 から選択します。


[スケジュール] タブ

このタスクのスケジュールの頻度とその他の設定を指定します。

オプションの定義

オプション 定義
ランタイム

タスクの実行 これらのオプションから、このタスクの頻度を選択します。

日指定 - 指定した日(複数可）にタスクを実行します。

毎日のタスクは、何日おきかに実行することも、月曜から日曜まで毎日実行することもできます。月曜から日曜の毎日以外に、特定の曜日のみにタスクを実行する場合は、毎週のタスクを使用することをお勧めします。

週指定 - 指定した週の特定の曜日にタスクを実行します（週、曜日ともに複数指定可）。

月指定 - 指定した月の特定の日にタスクを実行します（月、日ともに複数指定可）。

1 回のみ - 指定日にタスクを 1 回実行します。

起動時 - システムの起動時にタスクを実行し、タスクを 1 日に 1 回実行するかどうかおよびタスクを遅らせる時間を分単位で指定します。

ログオン時 - ログオン時にタスクを実行し、タスクを 1 日に 1 回実行するかどうかおよびタスクを遅らせる時間を分単位で指定します。

アイドル時 - コンピュータのアイドル時にタスクを実行し、タスクを開始するまでのアイドル時間を分単位で指定します。

タスクが開始され、完了する前にユーザがコンピュータの利用を再開した場合、タスクは完了するまで実行を続けます。

直ちに - 直ちにタスクを実行する。

ダイアルアップ時 - ダイアルアップ時にタスクを実行する。
開始時刻

スケジュールしたタスクの開始時刻を選択します。
UTC 時刻

協定世界時 (UTC)。すべての時間帯で同時にタスクを実行するには、このオプションを選択します。
現地時刻

それぞれの現地時間帯で個別にタスクを実行します。

注: デフォルト値 = 現地時間
ランダム化を有効にする

設定期間内で、タスクをランダムに実行します。

このオプションを選択する場合は、最大経過時間を時および分で指定します。

注:

1 分 (最小) ～ 23 時間 (最大) の間で、経過時間の間隔を指定します。たとえば、タスク スケジュールを 1:00 に、ランダム化を 3 時間に設定すると、タスクは 1:00 ～ 4:00 の任意の時刻に実行されます。

このオプションは、起動時、ログオン時、またはアイドル時にスケジュールされたタスクでは利用できません。
時

時間単位の時間。0 ～ 23時間から選択します。
分

分単位の時間。

注:
選択対象の分単位の時間は、どのオプションを選択したかによります。たとえば、次のように適用されます。
  • ランダム化を有効にする - 0 ～ 59分から選択します。
  • 実行し損ねたタスクを遅らせる時間 - 0 ～ 99分から選択します。
実行し損ねたら実行する

実行されなかったタスクを、コンピュータを再起動したときに実行します。タスクを実行するスケジュールの時刻にコンピュータがオフラインであれば、実行されなかった可能性があります。

注: この機能では、タスクを実行するスケジュールの時刻にオフラインになっているリモート ユーザおよびネットワークを完全に保護します。
実行し損ねたタスクを遅らせる期間

実行されなかったタスクを遅らせる期間を分単位で選択します。0 ～ 99 分から選択します。
日間隔

指定したとおり何日かおきに、このタスクを実行します。0 ～ 9999 日から選択します。

注: このオブションは、タスクのスケジュールが [毎日] のときのみ利用できます。
週間隔

指定したとおり何週間かおきに、このタスクを実行します。0 ～ 99 週から選択します。

このオプションを選択する場合、何週間おきか、および曜日も指定します。

注:

月の特定の日の場合、[日曜日]、[月曜日]、[火曜日]、[水曜日]、[木曜日]、[金曜日]、[土曜日] から選択します。

このオブションは、タスクのスケジュールが [週指定] のときのみ利用できます。

月の特定の日

月の特定の日にこのタスクを実行します。1 ～ 31 日から選択します。

このオプションを選択する場合、月の日数も指定します。

注: このオブションは、タスクのスケジュールが [月指定] のときのみ利用できます。
月の特定の曜日

月の特定の曜日にこのタスクを実行します。

このオプションを選択する場合、オカレンスと日にちも指定します。

注:

オカレンスの場合、[第 1]、[第 2]、[第 3]、[第 4]、[最終] から選択します。

月の特定の日の場合、[日曜日]、[月曜日]、[火曜日]、[水曜日]、[木曜日]、[金曜日]、[土曜日] から選択します。

このオプションは、タスクのスケジュールが [月指定] のときのみ利用できます。
月の選択

タスクを実行する月を指定します。

注: このオプションは、タスクのスケジュールが [月指定] のときのみ利用できます。
実行日

タスクを実行する日を指定します。

注: このオブションは、タスクのスケジュールが [1 回のみ] のときのみ利用できます。
このタスクを 1 日 1 回実行する

1日に 1 回このタスクを実行する。

注:

このオプションを選択しない場合、起動時またはログオン時に毎回タスクが実行されます。

このオプションは、[起動時]、[ログオン時]、または [ダイアルアップ接続時に実行] にスケジュールされたタスクでのみ利用できます。
タスクを遅らせる期間

タスクを遅らせる期間を分単位で指定します。0 ～ 99 から選択します。

注:

これにより、ユーザがログオンする時間またはログオン スクリプトを実行する時間が確保されます。

このオプションは、[起動時] または [ログオン時] にスケジュールされたタスクでのみ利用できます。
コンピュータが次の間アイドリング状態の場合

タスクを開始する前のコンピュータのアイドル時間を分単位で指定します。0 ～ 999 分から選択します。

注:

タスクが開始され、完了する前にユーザがコンピュータの利用を再開した場合、タスクは完了するまで実行を続けます。

このオブションは、タスクのスケジュールが [アイドル時] の場合のみ利用できます。
詳細設定

詳細オプションを設定します。

注: 詳細については、「詳細スケジュール オプション」を参照してください。


[タスク] タブ

このタスクのスケジュールを有効にしユーザ アカウント設定を指定します。

オプションの定義

オプション | 定義
有効 (スケジュールしたタスクが、指定時に実行されます) | 指定時に実行するタスクをスケジュールします。 注: タスクをスケジュールするには、このオプションを選択します。
次の時間実行が続くタスクを停止 | 指定した時間または分が経過した後タスクを停止させます。 注: タスクが完了する前に中断されると、次回開始時には中断したところからスキャンを再開します。
時 | タスクが停止するまでの時間単位の時間
分 | タスクが停止するまでの分単位の時間
ユーザ | このタスクを実行するユーザ ID を入力します。 注: 資格情報の使用はオプションです。ここで資格情報を入力しない場合、スケジュールしたタスクはローカル システム アカウントで実行されます。 詳細については、「ログオン権限」を参照してください。
ドメイン | 指定したユーザ ID のドメインを入力します。
パスワード | 指定したユーザ ID とドメインのパスワードを入力します。


[スクリプトスキャン] タブ

オプションの定義

望ましくないスクリプトの実行を防ぎます。

詳細については、「スクリプト スキャンとそのしくみ」を参照してください。

オプション | 定義
設定対象 | ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。 注: このオプションは ePolicy Orchestrator でのみ使用できます。
スクリプトスキャン | スクリプトのスキャンを有効にする - JavaScript および VBScript のスクリプトを実行前にスキャンします。
スクリプトスキャンの除外対象 | プロセス - スクリプトスキャンの除外対象をプロセス名で指定します。プロセス名の指定にはワイルドカードは使用できません。


[ユーザ定義の検知対象] タブ

オプションの定義

不審なプログラムとして処理する個別のファイルまたはプログラムを指定できます。

オプション 定義
設定対象 ドロップダウン リストから [ワークステーション] または [サーバ] を選択します。
注: このオプションは ePolicy Orchestrator でのみ使用できます。
ユーザ定義のアイテム
  • ファイル名 - 検出するファイルまたはプログラムの名前を指定します。

  • 説明 - 指定したファイルが検出されたときに通知に表示する説明を指定します。

注: ユーザ定義の望ましくないプログラムのサイズがゼロ バイトの場合は検出されません。